diff mbox series

[bug#51067,v2] gnu: Add ex-vi

Message ID PU1PR01MB2155123F9D3DDD32BDA169ED8DB69@PU1PR01MB2155.apcprd01.prod.exchangelabs.com
State New
Headers show
Series [bug#51067,v2] gnu: Add ex-vi | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Foo Chuan Wei Oct. 12, 2021, 8:50 p.m. UTC
* gnu/packages/text-editors.scm (ex-vi): New variable.
---
 gnu/packages/text-editors.scm | 45 +++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)


base-commit: 702bc2b89939165a3dc61096c21bb8b670a94713
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index d73f32c64e..58152bfccb 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -1195,3 +1195,48 @@  uncluttered user interface.  It supports a multitude of translation formats
 provided by the Translate Toolkit, including XLIFF and PO.")
     (home-page "https://virtaal.translatehouse.org/")
     (license license:gpl2+)))
+
+(define-public ex-vi
+  (package
+    (name "ex-vi")
+    (version "050325")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/ex-vi/ex-vi/"
+                                  version "/ex-" version ".tar.bz2"))
+              (sha256
+                (base32
+                  "0294cfxp91gyi0v3v4qdxcwlxp1nm986ir8r7d374ig9cz7yfjys"))))
+    (build-system gnu-build-system)
+    (inputs `(("ncurses" ,ncurses)))
+    (arguments `(#:make-flags
+                 (list (string-append "CC=" ,(cc-for-target))
+                       (string-append "PREFIX=" %output)
+                       "INSTALL = install"
+                       "TERMLIB = ncurses")
+                 #:phases
+                 (modify-phases %standard-phases
+                   (delete 'configure)
+                   (add-after 'unpack 'fix-build
+                     (lambda _
+                       ;; No need to create /var/preserve/
+                       (substitute* "Makefile"
+                         (("test -d \\$\\(DESTDIR\\)\\$\\(PRESERVEDIR\\) \
+\\|\\| mkdir -p \\$\\(DESTDIR\\)\\$\\(PRESERVEDIR\\)")
+                          "")
+                         (("chmod 1777 \\$\\(DESTDIR\\)\\$\\(PRESERVEDIR\\)")
+                          ""))
+                       #t)))
+                 #:tests? #f))
+    (home-page "http://ex-vi.sourceforge.net")
+    (synopsis "The Traditional Vi")
+    (description
+      "The traditional vi editor, ported to modern Unix systems.
+
+This implementation is derived from ex/vi 3.7 of 6/7/85 and the BSD termcap
+library, originally from the 2.11BSD distribution. All of them were changed to
+compile and run on newer POSIX compatible Unix systems. Support for
+international character sets was added, including support for multibyte locales
+(based on UTF-8 or East Asian encodings), and some changes were made to get
+closer to the POSIX.2 guidelines for ex and vi.")
+    (license license:bsd-4)))