diff mbox series

[bug#36230] Add emacs-multi-term

Message ID PR2PR08MB4810A3FE348EF6869E4E42BCB9FE0@PR2PR08MB4810.eurprd08.prod.outlook.com
State Accepted
Headers show
Series [bug#36230] Add emacs-multi-term | expand

Commit Message

Baptiste Strazzulla June 30, 2019, 11:38 a.m. UTC
And here is the third attempt. I changed the URL of the repository and pinned the only existing commit there.

On the side, I `./pre-inst-env guix lint emacs-multi-term` the previous patch that you had to correct because I remembered doing it before posting and as it turned out, nothing came out. There doesn't seem to be any additional options I should give to `guix lint` so I don't understand exactly why you had a more rigorous linting than mine. Do you have an idea?

Regards

Comments

Ludovic Courtès July 2, 2019, 3:58 p.m. UTC | #1
Hi,

Baptiste Strazzulla <bstrazzull@hotmail.fr> skribis:

> On the side, I `./pre-inst-env guix lint emacs-multi-term` the previous patch that you had to correct because I remembered doing it before posting and as it turned out, nothing came out. There doesn't seem to be any additional options I should give to `guix lint` so I don't understand exactly why you had a more rigorous linting than mine. Do you have an idea?

We should both get the same ‘guix lint’ output.  :-)

> From 9b8804a8fed18f77d72bb58113c823e3b29d7073 Mon Sep 17 00:00:00 2001
> From: Zzull <bstrazzull@hotmail.fr>
> Date: Sat, 15 Jun 2019 22:32:19 +0200
> Subject: [PATCH] gnu: Add emacs-multi-term
>
> * gnu/packages/emacs-xyz.scm (emacs-multi-term): New variable

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 9b8804a8fed18f77d72bb58113c823e3b29d7073 Mon Sep 17 00:00:00 2001
From: Zzull <bstrazzull@hotmail.fr>
Date: Sat, 15 Jun 2019 22:32:19 +0200
Subject: [PATCH] gnu: Add emacs-multi-term

* gnu/packages/emacs-xyz.scm (emacs-multi-term): New variable
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 238b204b3c..448f8122c8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16081,3 +16081,35 @@  themselves live in an Org-mode file.  As such, this leverages the power of
 Org-mode (the notes may have outlines, latex fragments, babel, etc...) while
 acting like notes that are made @emph{in} the document.")
     (license license:gpl3+)))
+
+(define-public emacs-multi-term
+  (let ((commit "0804b11e52b960c80f5cd0712ee1e53ae70d83a4"))
+    (package
+      (name "emacs-multi-term")
+      (version "1.2")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/manateelazycat/multi-term.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0apvidmvb7rv05qjnjhax42ma8wrimik5vxx620dlbv17svz7iyf"))))
+      (build-system emacs-build-system)
+      (inputs `(("zsh" ,zsh)))
+      (home-page "https://github.com/manateelazycat/multi-term")
+      (synopsis "Manage multiple terminal buffers in Emacs")
+      (description
+       "This package enhances @code{term.el} with the following features:
+
+@enumerate
+@item Functions to switch between multiple terminal buffers
+@item List of keys to be intercepted by @code{emacs-multi-term} instead of by
+the underlying terminal
+@item Kills the unused buffer left after exiting the terminal
+@item Kills the running sub-processes along with the terminal when killing the
+it forcibly
+@item Dedicated window for debugging program.
+@end enumerate")
+      (license license:gpl3+))))
-- 
2.22.0