diff mbox series

[bug#55701] gnu: Add go-github-com-google-go-jsonnet

Message ID PR2P264MB0446F74088C42B886528B68A96DA9@PR2P264MB0446.FRAP264.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#55701] gnu: Add go-github-com-google-go-jsonnet | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

JOULAUD François May 29, 2022, 9:36 a.m. UTC
This adds the jsonnet command. I would like to add too the jsonnet-fmt
command and the Python bindings but I struggle to understand how to do
it. I begin with the easy part using guix import.

I found that #:unpack-path and #:import-path are unintuitive, there is
room for better interface here, or at least some documentation.

* gnu/packages/golang.scm (go-github-com-google-go-jsonnet): New variable.
* gnu/packages/golang.scm (go-sigs-k8s-io-yaml): New variable.

Signed-off-by: François Joulaud <francois.joulaud@radiofrance.com>
---
gnu/packages/golang.scm | 52 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

--
2.36.1

Comments

Ludovic Courtès June 10, 2022, 9:02 p.m. UTC | #1
Hi François,

JOULAUD François <Francois.JOULAUD@radiofrance.com> skribis:

> This adds the jsonnet command. I would like to add too the jsonnet-fmt
> command and the Python bindings but I struggle to understand how to do
> it. I begin with the easy part using guix import.
>
> I found that #:unpack-path and #:import-path are unintuitive, there is
> room for better interface here, or at least some documentation.

Noted.  I’m not familiar with ‘go-build-system’; could you bring this up
on guix-devel@gnu.org?

> * gnu/packages/golang.scm (go-github-com-google-go-jsonnet): New variable.
> * gnu/packages/golang.scm (go-sigs-k8s-io-yaml): New variable.

I split it into two patches and improved descriptions, as per:

  https://guix.gnu.org/manual/devel/en/html_node/Submitting-Patches.html

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 820e6b54ab..ad34bd345f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9775,3 +9775,55 @@  (define-public go-github-com-go-chi-chi-v5
      "@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
decompose request handling into many smaller layers.")
     (license license:expat)))
+
+(define-public go-sigs-k8s-io-yaml
+  (package
+    (name "go-sigs-k8s-io-yaml")
+    (version "1.3.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/kubernetes-sigs/yaml")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0qxs0ppqwqrfqs4aywyn1h28xh1qlj5ds4drmygaz1plrxj02dqn"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "sigs.k8s.io/yaml"))
+    (propagated-inputs
+      `(("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)
+        ("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)))
+    (home-page "https://sigs.k8s.io/yaml")
+    (synopsis "YAML marshaling and unmarshaling support for Go")
+    (description
+      "kubernetes-sigs/yaml is a permanent fork of
+@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
+    (license (list license:expat license:bsd-3))))
+
+(define-public go-github-com-google-go-jsonnet
+  (package
+    (name "go-github-com-google-go-jsonnet")
+    (version "0.18.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/google/go-jsonnet")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1dghqygag123zkgh2vrnq82cdag5z0p03v3489pwhs06r5g27wm3"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/google/go-jsonnet/cmd/jsonnet"
+                 #:unpack-path "github.com/google/go-jsonnet"))
+    (propagated-inputs
+      `(("go-sigs-k8s-io-yaml" ,go-sigs-k8s-io-yaml)
+        ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)
+        ("go-github-com-sergi-go-diff" ,go-github-com-sergi-go-diff)
+        ("go-github-com-fatih-color" ,go-github-com-fatih-color)))
+    (home-page "https://github.com/google/go-jsonnet")
+    (synopsis "go-jsonnet")
+    (description
+      "Package jsonnet implements a parser and evaluator for jsonnet.")
+    (license license:asl2.0)))