diff mbox series

[bug#71410] gnu: Add wf-config.

Message ID PH0PR84MB136061E234447E58EBE42F9199FB2@PH0PR84MB1360.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers show
Series [bug#71410] gnu: Add wf-config. | expand

Commit Message

Wamm K. D. June 7, 2024, 9:07 a.m. UTC
* gnu/packages/wm.scm (wf-config): New variable.
---
 gnu/packages/wm.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 316caf5fa5..d22911544a 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -72,6 +72,7 @@ 
 ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
 ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
+;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -144,6 +145,7 @@  (define-module (gnu packages wm)
   #:use-module (gnu packages logging)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages man)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages mpd)
   #:use-module (gnu packages pciutils)
   #:use-module (gnu packages music)
@@ -3905,3 +3907,25 @@  (define-public yambar-wayland
 for short) for X11 and Wayland, that goes to great lengths to be both CPU and
 battery efficient---polling is only done when absolutely necessary.")
     (license license:expat)))
+
+(define-public wf-config
+  (package
+    (name "wf-config")
+    (version "0.8.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append "https://github.com/WayfireWM/" name "/"))
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256 (base32
+                       "07x6dapv2xyg0cn44dd2faw5gpk7mwfpbkpld9kyiaa9d44362z1"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list glm libxml2 wlroots libevdev))
+    (home-page "https://github.com/WayfireWM/wf-config")
+    (synopsis "Library for managing configuration files for Wayfire")
+    (description "The library powering Wayfire's configuration files which
+can set key and mouse bindings, configure input, and customize Wayfire
+plugins.")
+    (license license:expat)))