[bug#67755,v4,3/8] gnu: Add lunasvg.

Message ID PAXP251MB034896EA6C139CFFAA233F01F38B2@PAXP251MB0348.EURP251.PROD.OUTLOOK.COM
State New
Headers
Series None |

Commit Message

Sergio Pastor PĂ©rez Aug. 26, 2024, 10:01 p.m. UTC
  * gnu/packages/cpp.scm (lunasvg): New variable.

Change-Id: I77b7943e26e4e676a1575e3e33305f6f4476b401
---
 gnu/packages/cpp.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 49520d1ece..ec5156b1fa 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -467,6 +467,27 @@  (define-public libzen
 operating system functions.")
     (license license:zlib)))
 
+(define-public lunasvg
+  (package
+    (name "lunasvg")
+    (version "2.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sammycage/lunasvg")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s81phhi0q1mkzhx9fxgvv71s21yv50r01gi3bdwxzb3xrhj3yjk"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ; No tests.
+    (home-page "https://github.com/sammycage/lunasvg")
+    (synopsis "Standalone SVG rendering library in C++")
+    (description "Standalone SVG rendering library in C++.")
+    (license license:expat)))
+
 (define-public rttr
   (package
     (name "rttr")