[bug#67755,v4,6/8] gnu: Add xdgpp.
Commit Message
* gnu/packages/cpp.scm (xdgpp): New variable.
Change-Id: Ia11c0926e5b7f6e60c5dd48e8973cfd6391b1469
---
gnu/packages/cpp.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
@@ -619,6 +619,39 @@ (define-public dashel
combination of these streams.")
(license license:bsd-3)))
+(define-public xdgpp
+ (let ((commit "f01f810714443d0f10c333d4d1d9c0383be41375")
+ (revision "0"))
+ (package
+ (name "xdgpp")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~danyspin97/xdgpp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w8da10whrhc7j82jf90814m3blabkl9s0kg8hv8h2fj5y3ji7hw"))))
+ (build-system gnu-build-system)
+ (native-inputs (list catch2))
+ (arguments
+ (list
+ #:test-target "test"
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "xdg.hpp"
+ (string-append #$output "/include")))))))
+ (home-page "https://git.sr.ht/~danyspin97/xdgpp")
+ (synopsis
+ "C++17 header-only implementation of the XDG Base Directory Specification")
+ (description
+ "C++17 header-only implementation of the XDG Base Directory Specification.")
+ (license license:expat))))
+
(define-public xsimd
(package
(name "xsimd")