[bug#67755,v4,5/8] gnu: Add nativefiledialog-extended.

Message ID PAXP251MB034859C62EEBDA2E8D5FA7F6F38B2@PAXP251MB0348.EURP251.PROD.OUTLOOK.COM
State New
Headers
Series None |

Commit Message

Sergio Pastor PĂ©rez Aug. 26, 2024, 10:01 p.m. UTC
  * gnu/packages/cpp.scm (nativefiledialog-extended): New variable.

Change-Id: I89ed4554db3ec8075bbb7d50bbfb4b99cae81a27
---
 gnu/packages/cpp.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index dd6488ccd1..184d3a889c 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3325,6 +3325,31 @@  (define-public mpark-variant
 based on the implementation of std::variant in libc++.")
     (license license:boost1.0)))
 
+(define-public nativefiledialog-extended
+  (package
+    (name "nativefiledialog-extended")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/btzy/nativefiledialog-extended")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15l0jy3v4p6rgg9dk8zr80lqp51s32ii62cm4s90400ragdgh10v"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+    (native-inputs (list pkg-config))
+    (inputs (list gtk+))
+    (home-page "https://github.com/btzy/nativefiledialog-extended")
+    (synopsis "Native file dialog library with C and C++ bindings")
+    (description
+     "Cross platform (Windows, Mac, Linux) native file dialog
+library with C and C++ bindings, based on mlabbe/nativefiledialog.")
+    (license license:zlib)))
+
 (define-public tsl-hopscotch-map
   (package
     (name "tsl-hopscotch-map")