diff mbox series

[bug#52027] Add lz4json

Message ID PA4PR03MB710147BABD7D9CA9241A3CE1B99E9@PA4PR03MB7101.eurprd03.prod.outlook.com
State Accepted
Headers show
Series [bug#52027] Add lz4json | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Baptiste Strazzulla Nov. 21, 2021, 9:54 p.m. UTC
Here is the revised version.

Regards again

Comments

Nicolas Goaziou Nov. 22, 2021, 10:24 a.m. UTC | #1
Hello,

Baptiste Strazzulla <bstrazzull@hotmail.fr> writes:

> Here is the revised version.

Thank you. I added a copyright line for you in gnuzilla.scm and applied
your patch, with the minor tweaks below.

> Subject: [PATCH] gnu: Add lz4json

I added a final full stop to the line.

> * gnu/packages/gnuzilla.scm (lz4json)
>   New variable

I wrote:

  * gnu/packages/gnuzilla.scm (lz4json): New variable.

Regards,
diff mbox series

Patch

From db07a9915dc6237f057939c1877511e3f8e1fd02 Mon Sep 17 00:00:00 2001
From: Zzull <bstrazzull@hotmail.fr>
Date: Sun, 21 Nov 2021 22:43:15 +0100
Subject: [PATCH] gnu: Add lz4json

* gnu/packages/gnuzilla.scm (lz4json)
  New variable
---
 gnu/packages/gnuzilla.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 9edfcaa2ab..efd031f90d 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1992,3 +1992,41 @@  (define-public firefox-decrypt
     (description "Firefox Decrypt is a tool to extract passwords from
 Mozilla (Firefox, Waterfox, Thunderbird, SeaMonkey) profiles.")
     (license license:gpl3+)))
+
+(define-public lz4json
+  (package
+    (name "lz4json")
+    (version "2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/andikleen/lz4json")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xxn8yzr6j8j6prmbj6mxspdczigarfiv3vlm9k70yxmky65ijh3"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("lz4" ,lz4)))
+    (arguments
+     `(#:tests? #f                              ; no check target
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)                    ; no configure script
+         (replace 'install                      ; no install target
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin"))
+                    (man (string-append out "/share/man/man1")))
+               (install-file "lz4jsoncat" bin)
+               (install-file "lz4jsoncat.1" man)))))
+       #:make-flags `(,(string-append "CC=" ,(cc-for-target)))))
+    (home-page "https://github.com/andikleen/lz4json")
+    (synopsis "C decompress tool for mozilla lz4json format")
+    (description
+     "@code{lz4json} is a little utility to unpack lz4json files as generated
+by Firefox's bookmark backups and session restore.  This is a different format
+from what the normal lz4 utility expects.  The data is dumped to stdout.")
+    (license license:bsd-2)))
-- 
2.33.1