diff mbox series

[bug#49581] Add git-issues

Message ID OtwZjjiac_X-7rMHJdn-ruFUDl4kpeL7dC6XcQY9FFDArpj5VP9upJYc9ohZfJ73K8AgvrdaG8lE0oji5nmvITzMKgI7gffpzl-oYUWxCl8=@protonmail.com
State New
Headers show
Series [bug#49581] Add git-issues | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 15, 2021, 5:01 p.m. UTC
From dbfbc69932b29dd5b3a6bed2de3f67d89bc50bfa Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 15 Jul 2021 18:58:40 +0200
Subject: [PATCH] gnu: Add git-issues


--
2.31.1

Comments

Giovanni Biscuolo July 17, 2021, 9:39 a.m. UTC | #1
Hello phodina,

thank you for your patch!

phodina via Guix-patches via <guix-patches@gnu.org> writes:

[...]

> +(define-public git-issues
> +(package
> +  (name "git-issues")
> +  (version "67aacad35888b4c51e2d7be35c86fef137874f12")

Upstream does not publish releases (does not tag branches): could you
please just add a comment, it could be useful to other Guix developers,
also to remember to check if things will change in the future.

[...]

> +  (license license:gpl2)))

The source code of the main script [1] states the license is gpl3+:
«version 3 of the License, or (at your option) any later version.»

Can you please submit an updated version of your patch?

Thanks! Gio'


[1] https://github.com/dspinellis/git-issue/blob/master/git-issue.sh
Tobias Geerinckx-Rice July 17, 2021, 10:23 a.m. UTC | #2
Hi Petr,

In addition to what Gio' wrote:

On 2021-07-15 19:01, phodina via Guix-patches via wrote:
> +  (description "This is a minimalist decentralized issue management
> system based on Git, offering (optional) biderectional integration

'optional bidirectional'.

> with GitHub and GitLab issue management. It has the following
> advantages over other systems.")

If what came next wasn't too promotional, you can write 'features' 
instead, and use @enumerate to list [a subset of] them.  Otherwise the 
description's rather short.

Kind regards,

T G-R

Sent from a Web browser. Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7c1dbe8b26..47768fdc05 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1267,6 +1267,31 @@  subcommands helps automate some parts of the flow to make working with it a
 lot easier.")
     (license license:bsd-2)))

+(define-public git-issues
+(package
+  (name "git-issues")
+  (version "67aacad35888b4c51e2d7be35c86fef137874f12")
+  (source (origin
+            (method git-fetch)
+            (uri
+	      (git-reference
+		(url "https://github.com/dspinellis/git-issue")
+		(commit version)))
+            (sha256
+             (base32
+              "1z6dpwbikmiq5acpbji4kvmxqc2jw995rfk5703k5mvp5ps9a29q"))))
+  (build-system gnu-build-system)
+  (arguments
+    '(#:tests? #f
+      #:make-flags (list (string-append "PREFIX="(assoc-ref %outputs "out")))
+      #:phases (modify-phases %standard-phases
+		(delete 'configure)
+		(delete 'build))))
+  (synopsis "Git-based decentralized issue management")
+  (description "This is a minimalist decentralized issue management system based on Git, offering (optional) biderectional integration with GitHub and GitLab issue management. It has the following advantages over other systems.")
+  (home-page "https://github.com/dspinellis/git-issue")
+  (license license:gpl2)))
+
 (define-public stgit
   (package
     (name "stgit")