[bug#76274] gnu: Add chatterino
Commit Message
One last patch *crosses-fingers*.
I realized I was missing the proper namespace for the license module.
Should all be good now.
* gnu/packages/messaging.scm (chatterino): New variable.
Change-Id: I0c2dd4863c9953159f059d18fb9b554da36e087a
---
gnu/packages/messaging.scm | 50 ++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)
base-commit: 7f0ec135d1bf6fd8b7bff84bc176b6c61fdee75d
@@ -220,6 +220,56 @@ (define-public biboumi
users take part in IRC discussions, using their favourite XMPP client.")
(license license:zlib)))
+(define-public chatterino
+ (package
+ (name "chatterino")
+ (version "2.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Chatterino/chatterino2")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fs13vdxbq2dbxr21wp9mvn33bhvnmg17rqdd6yawsgslab2lssv"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list "-DCMAKE_BUILD_TYPE=Release" "-DCHATTERINO_UPDATER=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check)
+ (add-before 'configure 'setvars
+ (lambda _
+ (setenv "GIT_HASH" "3f3a31db")))
+ (add-after 'install 'wrap-executable
+ (lambda* _
+ (let ((plugin-path (getenv "QT_PLUGIN_PATH")))
+ (wrap-program (string-append #$output "/bin/chatterino")
+ `("QT_PLUGIN_PATH" ":" prefix
+ (,plugin-path)))))))))
+ (native-inputs (list pkg-config))
+ (inputs (list qtbase
+ qtsvg
+ qttools
+ qt5compat
+ boost
+ bash-minimal
+ openssl
+ libsecret
+ libnotify
+ qtwayland
+ qtimageformats))
+ (synopsis "Chat client for Twitch")
+ (description
+ "Chatterino is a chat client for Twitch chat.
+It aims to be an improved/extended version of the Twitch web chat.")
+ (home-page "https://chatterino.com")
+ (license license:expat)))
+
(define-public omemo-wget
(package
(name "omemo-wget")