diff mbox series

[bug#51686,1/2] gnu: Add emacs-plz.

Message ID OcKRlfxfxnbSKU5afQU3l0_4SkILPtrd0ed5RktBJBRMVKIUB2UDPT0uMVLp_uZJgZ_saQf3t0bfoK73E6ciOOi1oWQVQZKDO1PCQrxa-lw=@protonmail.com
State Accepted
Headers show
Series [bug#51686,1/2] gnu: Add emacs-plz. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 8, 2021, 11:11 a.m. UTC
Hi,

here's a set of 2 patches to add Matrix client support to Emacs.

However, there is one warning about images:

Warning (ement): This Emacs was not built with ImageMagick support, nor does it support Cairo/XRender scaling, so images can't be displayed in Ement

Emacs inputs don't list imagemagick. However, it's deleted from a list in emacs-no-x.

So should we patch Emacs as the magickimage is missing by mistake or is there a reason?

Petr

* gnu/packages/emacs-xyz.scm (emacs-plz): Add variable.

---8<--------cut here------------------<8---
--
2.33.1

Comments

Nicolas Goaziou Nov. 8, 2021, 11:27 a.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> here's a set of 2 patches to add Matrix client support to Emacs.

Thank you.

> However, there is one warning about images:
>
> Warning (ement): This Emacs was not built with ImageMagick support, nor does it support Cairo/XRender scaling, so images can't be displayed in Ement
>
> Emacs inputs don't list imagemagick. However, it's deleted from a list in emacs-no-x.
>
> So should we patch Emacs as the magickimage is missing by mistake or
> is there a reason?

You need to provide a different emacs package to build it, using keyword
#:emacs.  See, e.g., emacs-auctex definiton.

Regards,
Nicolas Goaziou Nov. 8, 2021, 11:31 a.m. UTC | #2
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> +    (package
> +      (name "emacs-plz")
> +      (version (git-version "0.0" revision commit))

This should be "0.1-pre", not "0.0"

> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://github.com/alphapapa/plz.el")
> +               (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32
> +           "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
> +      (build-system emacs-build-system)
> +      (inputs `(("curl" ,curl)))
> +      (home-page "https://github.com/alphapapa/plz.el")
> +      (synopsis "HTTP library for Emacs")
> +      (description "This package provides HTTP library for Emacs.  It uses curl
> +as a backend, which avoids some of the issues with using Emacs’s built-in
> +url.")

Nitpick: I would add "... built-in url library."

Regards,
phodina Nov. 10, 2021, 1:23 p.m. UTC | #3
Hi Nicolas,

thanks for you're feedback :-)

--
Kind regards
Petr
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 543ce6303a..c7e5c05030 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15033,6 +15033,31 @@  (define-public emacs-emamux
 multiplexer.")
     (license license:gpl3+)))

+(define-public emacs-plz
+  (let ((commit "7e456638a651bab3a814e3ea81742dd917509cbb")
+        (revision "1"))
+    (package
+      (name "emacs-plz")
+      (version (git-version "0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/alphapapa/plz.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "05kgxrps1s20im5hhq799nrs3615bvssm4r0ysgmwm203mmzsjgj"))))
+      (build-system emacs-build-system)
+      (inputs `(("curl" ,curl)))
+      (home-page "https://github.com/alphapapa/plz.el")
+      (synopsis "HTTP library for Emacs")
+      (description "This package provides HTTP library for Emacs.  It uses curl
+as a backend, which avoids some of the issues with using Emacs’s built-in
+url.")
+      (license license:gpl3+))))
+
 (define-public emacs-rpm-spec-mode
   (package
     (name "emacs-rpm-spec-mode")