diff mbox series

[bug#63424] GNOME tracker does not work with tracker-miners

Message ID Objmo-NgQrAZgNLj9gCbT6xspwbOj84ykv6MNoIocEdjvQGHAiyYLRk_8_zfiNLUW9Y9Sc-l8UJ72mVqhYzNO3gISwzegtKbCIlDCDQfxmI=@proton.me
State New
Headers show
Series [bug#63424] GNOME tracker does not work with tracker-miners | expand

Commit Message

Sughosha June 16, 2023, 8:22 p.m. UTC
Hi Liliana,

I found out that tracker also looks for "TRACKER_CLI_SUBCOMMANDS_DIR".
I tested it and it worked!


* gnu/packages/gnome.scm (tracker-miners)[native-search-paths]: Add
search path for "TRACKER_CLI_SUBCOMMANDS_DIR".
---
 gnu/packages/gnome.scm | 6 ++++++
 1 file changed, 6 insertions(+)

--
libgit2 1.5.1

Comments

Liliana Marie Prikler June 16, 2023, 10:01 p.m. UTC | #1
Am Freitag, dem 16.06.2023 um 20:22 +0000 schrieb Sughosha:
> Hi Liliana,
> 
> I found out that tracker also looks for
> "TRACKER_CLI_SUBCOMMANDS_DIR".
> I tested it and it worked!
Cool, I've applied some stylistic changes and prepared a format-abiding
commit message, but otherwise LGTM.  The actual push will have to wait
a week, though :)

Cheers
Sughosha June 23, 2023, 5:16 p.m. UTC | #2
Even though tracker is able to find tracker-miners executables, GNOME Music is not showing any of my music file in the ~/Music folder. It may have another problem.
Liliana Marie Prikler June 25, 2023, 12:38 p.m. UTC | #3
Am Freitag, dem 23.06.2023 um 17:16 +0000 schrieb Sughosha:
> Even though tracker is able to find tracker-miners executables, GNOME
> Music is not showing any of my music file in the ~/Music folder. It
> may have another problem.
I pushed the current patch regardless.  Hope that helps.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 22588ff..d50010b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9607,6 +9607,12 @@  (define-public tracker-miners
            tracker
            upower
            zlib))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "TRACKER_CLI_SUBCOMMANDS_DIR")
+            (separator #f) ;single entry
+            (files `(,(string-append "libexec/tracker"
+                                     (version-major version)))))))
     (synopsis "Metadata database, indexer and search tool")
     (home-page "https://wiki.gnome.org/Projects/Tracker")
     (description