diff mbox series

[bug#47546,2/2] gnu: Add python-typogrify.

Message ID OSZP286MB0664E66AE4754EB18C3010BAA37B9@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#47548,1/2] gnu: Add python-smartypants. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

宋文武 April 1, 2021, 2:50 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/python-xyz.scm (python-typogrify): New variable.
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Leo Famulari April 1, 2021, 8:19 p.m. UTC | #1
On Thu, Apr 01, 2021 at 10:50:48PM +0800, iyzsong@outlook.com wrote:
> From: 宋文武 <iyzsong@member.fsf.org>
> 
> * gnu/packages/python-xyz.scm (python-typogrify): New variable.

LGTM, thanks!
宋文武 April 2, 2021, 10:40 a.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Thu, Apr 01, 2021 at 10:50:48PM +0800, iyzsong@outlook.com wrote:
>> From: 宋文武 <iyzsong@member.fsf.org>
>> 
>> * gnu/packages/python-xyz.scm (python-typogrify): New variable.
>
> LGTM, thanks!

Pushed, thank you for review!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dfce35a212..c22f615bd9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24372,3 +24372,34 @@  entities
 @item Three consecutive dots (... or . . .) into an ellipsis entity
 @end enumerate")
     (license license:bsd-3)))
+
+(define-public python-typogrify
+  (package
+    (name "python-typogrify")
+    (version "2.0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "typogrify" version))
+              (sha256
+               (base32
+                "0f6b2gnnxjbx1fbmkcscc6qjr4hi78kwm1wx4b766ha3va66dr4b"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "nosetests" "-v"))))))
+    (propagated-inputs
+     `(("python-smartypants" ,python-smartypants)))
+    (native-inputs
+     ;; For tests.
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/mintchaos/typogrify")
+    (synopsis "Filters to transform text into typographically-improved HTML")
+    (description
+     "@code{typogrify} provides a set of custom filters that automatically
+apply various transformations to plain text in order to yield
+typographically-improved HTML.  While often used in conjunction with Jinja and
+Django template systems, the filters can be used in any environment.")
+    (license license:bsd-3)))