diff mbox series

[bug#47643] WIP-GNOME

Message ID OSZP286MB0664C1ED49DBC28F9064AF60A3729@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#47643] WIP-GNOME | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

宋文武 April 10, 2021, 8:47 a.m. UTC
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> From: Raghav Gururajan <rg@raghavgururajan.name>
>
> * gnu/packages/gstreamer.scm (gstreamer)[version]: Update to 1.18.4.
> [arguments](glib-or-gtk): New argument.
> [propagated-inputs]: Add elfutils, glib-networking and libunwind.
> [native-inputs]: Add bash-completion and gettext-minimal.
> [inputs]: Add gmp, gsl, gtk+ and libcap.

Hello, I make some updates:

- Move elfutils and libunwind to inputs, as they are not listed in
  pkg-config files, so don't need to be propagated.

- Remove glib-networking and glib-or-gtk?.  libgstnet could use it, but
  glib-networking is a runtime dependency (needed to be wraped with
  GIO_EXTRA_MODULES), I'd like add it later if we find it really useful
  (eg: when use gst-launch to play https remote media).

- Remove gtk+, as it only needed by build a not to be installed example
  (controller-graph).

- Mention gsl is for tests and the update of synopsis.

Hope it useful, thank you and rg!
diff mbox series

Patch

From fd5e8e52198d1cc3ca4c9b888a366855a5b84aeb Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Fri, 9 Apr 2021 20:38:50 +0200
Subject: [PATCH] gnu: gstreamer: Update to 1.18.4.

* gnu/packages/gstreamer.scm (gstreamer)[version]: Update to 1.18.4.
[synopsis]: Change to "Multimedia framework".
[native-inputs]: Add bash-completion and gettext-minimal.
[inputs]: Add elfutils, gmp, libcap, libunwind and gsl.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/gstreamer.scm | 37 +++++++++++++++++++++++++------------
 1 file changed, 25 insertions(+), 12 deletions(-)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 9ec737beb2..ef0fd16e5f 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -40,6 +40,7 @@ 
   #:use-module (gnu packages audio)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages curl)
@@ -62,7 +63,9 @@ 
   #:use-module (gnu packages libunwind)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages mp3)
+  #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
   #:use-module (gnu packages ocr)
@@ -461,16 +464,16 @@  the GStreamer multimedia framework.")
 (define-public gstreamer
   (package
     (name "gstreamer")
-    (version "1.18.2")
+    (version "1.18.4")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append
-            "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-            version ".tar.xz"))
-      (sha256
-       (base32
-        "0ijlmvr660m8zn09xlmnq1ajrziqsivp2hig5a9mabhcjx7ypkb6"))))
+       (method url-fetch)
+       (uri (string-append
+             "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
+             version ".tar.xz"))
+       (sha256
+        (base32
+         "1igv9l4hm21kp1jmlwlagzs7ly1vaxv1sbda29q8247372dwkvls"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases
@@ -487,24 +490,34 @@  the GStreamer multimedia framework.")
                        (("tcase_add_test \\(tc_chain, test_stress_cleanup_unschedule.*")
                         "")
                        (("tcase_add_test \\(tc_chain, test_stress_reschedule.*")
-                      ""))
+                        ""))
                      #t)))
                '()))))
-    (propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
+    (propagated-inputs
+     `(("glib" ,glib)))                 ; required by gstreamer-1.0.pc.
     (native-inputs
-     `(("bison" ,bison)
+     `(("bash-completion" ,bash-completion)
+       ("bison" ,bison)
        ("flex" ,flex)
+       ("gettext" ,gettext-minimal)
        ("glib" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
+    (inputs
+     `(("elfutils" ,elfutils)
+       ("gmp" ,gmp)
+       ("libcap" ,libcap)
+       ("libunwind" ,libunwind)
+       ;; For tests.
+       ("gsl" ,gsl)))
     (native-search-paths
      (list (search-path-specification
             (variable "GST_PLUGIN_SYSTEM_PATH")
             (files '("lib/gstreamer-1.0")))))
     (home-page "https://gstreamer.freedesktop.org/")
-    (synopsis "Multimedia library")
+    (synopsis "Multimedia framework")
     (description
      "GStreamer is a library for constructing graphs of media-handling
 components.  The applications it supports range from simple Ogg/Vorbis
-- 
2.30.0