diff mbox series

[bug#47643] WIP-GNOME: gst-plugins-base

Message ID OSZP286MB0664A9BA47B725DB977D4A50A3729@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#47643] WIP-GNOME: gst-plugins-base | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

宋文武 April 10, 2021, 10:35 a.m. UTC
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> From: Raghav Gururajan <rg@raghavgururajan.name>
>
> * gnu/packages/gstreamer.scm (gst-plugins-base)[version]: Update to 1.18.4.
> [arguments](glib-or-gtk): New argument.
> [configure-flags](gl): Remove flag.
> [phases](pre-check): New phase.
> [native-inputs]: Add gettext-minimal, gsettings-desktop-schemas, perl
> and xorg-server-for-tests.
> [propagated-inputs]: Add glib-networking.
> [synopsis]: Fix indentation.

Hello, what 'glib-or-gtk? #t', glib-networking,
gsettings-desktop-schemas and perl are useful for?

Also I think it's better split this into 2 patches, one for update, one
for adding inputs. eg: (I also add some more inputs)
What do you think, thanks!

Comments

Raghav Gururajan April 10, 2021, 12:06 p.m. UTC | #1
> Hello, what 'glib-or-gtk? #t', glib-networking,
> gsettings-desktop-schemas and perl are useful for?

glib-or-gtk is to compile glib schemas and wrapping the binaries gi 
modules of its inputs.
IIRC, gsettings-desktop-schemas is used during tests.
IIRC, perl used in patch-shebangs phase for test scripts.

> Also I think it's better split this into 2 patches, one for update, one
> for adding inputs. eg: (I also add some more inputs)

TThese inputs doesn't enable features, so I think it should be fine as a 
part of update.

Regards,
RG.
diff mbox series

Patch

From 022de6b475411c1ab52fd63c4c12c4327cf2f4eb Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Sat, 10 Apr 2021 18:17:01 +0800
Subject: [PATCH 2/2] gnu: gst-plugins-base: Enable more features.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/gstreamer.scm (gst-plugins-base)
[inputs]: Add graphene, iso-codes, libgudev, libjpeg-turbo, libpng,
libvisual, mesa, wayland-protocols, wayland.
[native-inputs]: Add gettext-minimal and xorg-server-for-test.
[arguments]: Remove '-Dgl=disabled' from configure flags.  Add pre-check phase.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
---
 gnu/packages/gstreamer.scm | 37 ++++++++++++++++++++++++++++++-------
 1 file changed, 30 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e9f5444a7..0b5f14342e 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,6 +559,7 @@  This package provides the core library and elements.")
              '()
              `(("orc" ,orc)))))         ;required by gstreamer-audio-1.0.pc
     (inputs
+     ;; TODO: Add libvorbisidec
      `(("cdparanoia" ,cdparanoia)
        ("pango" ,pango)
        ("libogg" ,libogg)
@@ -569,21 +570,43 @@  This package provides the core library and elements.")
        ("libXext" ,libxext)
        ("libxv" ,libxv)
        ("alsa-lib" ,alsa-lib)
-       ("opus" ,opus)))
+       ("opus" ,opus)
+       ("graphene" ,graphene)
+       ("iso-codes" ,iso-codes)
+       ("libgudev" ,libgudev)
+       ("libjpeg" ,libjpeg-turbo)
+       ("libpng" ,libpng)
+       ("libvisual" ,libvisual)
+       ("mesa" ,mesa)
+       ("wayland-protocols" ,wayland-protocols)
+       ("wayland" ,wayland)))
     (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("glib:bin" ,glib "bin")
-        ("gobject-introspection" ,gobject-introspection)
-        ("python-wrapper" ,python-wrapper)))
+     `(("pkg-config" ,pkg-config)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("python-wrapper" ,python-wrapper)
+       ("gettext" ,gettext-minimal)
+       ("xorg-server" ,xorg-server-for-tests)))
     (arguments
-     `(#:configure-flags '("-Dgl=disabled")
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          ,@%common-gstreamer-phases
          (add-before 'configure 'patch
            (lambda _
              (substitute* "tests/check/libs/pbutils.c"
                (("/bin/sh") (which "sh")))
+             #t))
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests require a running X server.
+             (system "Xvfb :1 +extension GLX &")
+             (setenv "DISPLAY" ":1")
+             ;; Tests write to $HOME.
+             (setenv "HOME" (getcwd))
+             ;; Tests look for $XDG_RUNTIME_DIR.
+             (setenv "XDG_RUNTIME_DIR" (getcwd))
+             ;; For missing '/etc/machine-id'.
+             (setenv "DBUS_FATAL_WARNINGS" "0")
              #t)))))
     (home-page "https://gstreamer.freedesktop.org/")
     (synopsis
-- 
2.30.0