diff mbox series

[bug#49641] gnu: Add drawterm.

Message ID OSZP286MB06643A7FD015917AFE02D4A3A3E19@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#49641] gnu: Add drawterm. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

宋文武 July 19, 2021, 12:16 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/plan9.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk           |  1 +
 gnu/packages/plan9.scm | 66 ++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 67 insertions(+)
 create mode 100644 gnu/packages/plan9.scm

Comments

宋文武 July 22, 2021, 11:56 a.m. UTC | #1
Pushed now!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 62a5e41a46..e94f467e40 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -450,6 +450,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/php.scm				\
   %D%/packages/piet.scm			\
   %D%/packages/pkg-config.scm			\
+  %D%/packages/plan9.scm			\
   %D%/packages/plotutils.scm			\
   %D%/packages/poedit.scm				\
   %D%/packages/polkit.scm			\
diff --git a/gnu/packages/plan9.scm b/gnu/packages/plan9.scm
new file mode 100644
index 0000000000..e306e04d85
--- /dev/null
+++ b/gnu/packages/plan9.scm
@@ -0,0 +1,66 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 宋文武 <iyzsong@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages plan9)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages xorg))
+
+(define-public drawterm
+  (let ((revision "1")
+        (commit "c97fe4693f6112504d6f13fab46f7cc8b27685c1"))
+    (package
+      (name "drawterm")
+      (version (git-version "20210628" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "git://git.9front.org/plan9front/drawterm")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "059sl60ap6c9lz8k91k6bd34694a290wm0s93b2vfszzzv683spw"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:make-flags (list "CONF=unix"
+                            (string-append "CC=" ,(cc-for-target)))
+         #:tests? #f                    ; no tests
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)          ; no configure script
+           (replace 'install            ; no install target
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin/"))
+                      (man (string-append out "/share/man/man1/")))
+                 (install-file "drawterm" bin)
+                 (install-file "drawterm.1" man)))))))
+      (inputs
+       `(("libx11" ,libx11)
+         ("libxt" ,libxt)))
+      (synopsis "Connect to Plan 9 systems")
+      (home-page "http://drawterm.9front.org")
+      (description
+       "@command{drawterm} is a client for connecting venerable systems to
+Plan 9 systems.  It behaves like a Plan 9 kernel and will attempt to
+reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
+      (license license:expat))))