[bug#55769] gnu: Add xwhite.

Message ID OS3P286MB112784C433EB82843A61F475BEA19@OS3P286MB1127.JPNP286.PROD.OUTLOOK.COM
State New
Headers
Series [bug#55769] gnu: Add xwhite. |

Commit Message

derekchuank@outlook.com June 3, 2022, 7:07 p.m. UTC
  I've fixed all the issues you mentioned: adopt meson build system, add GPTv2-only license in README, fix return values in code and a new description. Again, Thank you very much for your detailed guidance and patience.


 gnu/packages/xdisorg.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
  

Comments

Maxime Devos June 3, 2022, 7:32 p.m. UTC | #1
user guix
usertags 55769 + reviewed looks-good reviewed-looks-good
thanks
(list available at <https://debbugs.gnu.org/cgi/pkgreport.cgi?tag=reviewed-looks-good&users=guix>)

derekchuank@outlook.com schreef op vr 03-06-2022 om 19:07 [+0000]:
> +     (uri
> +      (string-append "https://github.com/derekchuank/xwhite/"
> +                     "releases/download/v" version
> +                     "/xwhite-" version ".tar.gz"))
> +     (sha256
> +      (base32
> "0jbnlj5a91ib4anprmylqqnbv9wa73cr7fsc1s54df0a0w5yq8sz"))))


New package definition LGTM (looks good to me).
The hash matches, without any malware in the tarball.
Assuming it actually builds (I haven't checked) it should be fine to
apply.

Greetings,
Maxime.
  
Ludovic Courtès June 7, 2022, 4:28 p.m. UTC | #2
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

> user guix
> usertags 55769 + reviewed looks-good reviewed-looks-good
> thanks
> (list available at <https://debbugs.gnu.org/cgi/pkgreport.cgi?tag=reviewed-looks-good&users=guix>)
>
> derekchuank@outlook.com schreef op vr 03-06-2022 om 19:07 [+0000]:
>> +     (uri
>> +      (string-append "https://github.com/derekchuank/xwhite/"
>> +                     "releases/download/v" version
>> +                     "/xwhite-" version ".tar.gz"))
>> +     (sha256
>> +      (base32
>> "0jbnlj5a91ib4anprmylqqnbv9wa73cr7fsc1s54df0a0w5yq8sz"))))
>
>
> New package definition LGTM (looks good to me).
> The hash matches, without any malware in the tarball.
> Assuming it actually builds (I haven't checked) it should be fine to
> apply.

Applied.  Thanks Derek and Maxime!

Ludo’.
  

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index e5a98edb35..1c09128c17 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1499,6 +1500,37 @@  (define-public redshift-wayland
 protocol.")
       (license license:gpl3+))))

+(define-public xwhite
+  (package
+   (name "xwhite")
+   (version "0.0.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri
+      (string-append "https://github.com/derekchuank/xwhite/"
+                     "releases/download/v" version
+                     "/xwhite-" version ".tar.gz"))
+     (sha256
+      (base32 "0jbnlj5a91ib4anprmylqqnbv9wa73cr7fsc1s54df0a0w5yq8sz"))))
+   (build-system meson-build-system)
+   (arguments
+    `(#:tests? #f)) ; No test suite.
+   (native-inputs
+    (list pkg-config))
+   (inputs
+    (list libxrandr))
+   (home-page "https://github.com/derekchuank/xwhite")
+   (synopsis "Adjust the color balance")
+   (description "@command{xwhite} is a command line tool for adjusting the colour
+balance of screen.  It is based on xrandr's gamma correction and brightness adjustment.
+As such, it can only be used for X displays and not Wayland displays.  It is typically
+used for tuning the color balance and color temperature.  It has a similar function as
+@command{redshift -P -g R:G:B -O temperature}, but @command{xwhite} is more flexible
+in that it does not keep the white color fixed, suitable for setting the white color
+to an arbitrary balanced color.")
+   (license license:gpl2)))
+
 (define-public gammastep
   (package
     (name "gammastep")