diff mbox series

[bug#50657] gnu: Add vpn-slice.

Message ID ORACe3vNVei78749NpMdTd9U8KD6zmRH5NjY1E44BWRMPXaJfe3DQjujYWbCWvIbAV3hTQtTby3MuSA1qapkoaPaxTo2OP-G0HSSr8zyD_s=@protonmail.com
State New
Headers show
Series [bug#50657] gnu: Add vpn-slice. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 10:23 a.m. UTC
* gnu/packages/vpn.scm (vpn-slice): New variable.

--
2.32.0

Comments

Xinglu Chen Sept. 20, 2021, 12:37 p.m. UTC | #1
On Sat, Sep 18 2021, phodina via Guix-patches via wrote:

> * gnu/packages/vpn.scm (vpn-slice): New variable.
>
> diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
> index 330a3271b4..4d49597564 100644
> --- a/gnu/packages/vpn.scm
> +++ b/gnu/packages/vpn.scm
> @@ -18,6 +18,7 @@
>  ;;; Copyright © 2021 Domagoj Stolfa <ds815@gmx.com>
>  ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
>  ;;; Copyright © 2021 jgart <jgart@dismail.de>
> +;;; Copyright © 2021 Petr Hodina  <phodina@protonmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -432,6 +433,31 @@ file for more details.")
>             ;; src/libstrongswan/plugins/des/des_crypter.c
>             license:bsd-4))))
>
> +(define-public vpn-slice
> +  (package
> +    (name "vpn-slice")
> +    (version "0.15")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "vpn-slice" version))
> +        (sha256
> +          (base32
> +            "0lv3g1bq6ssz6fn6zlzn12dahc4d7nf7kjwxsnb5d7gdrfp36lbx"))))
> +    (build-system python-build-system)
> +    (native-inputs `(("python-pytest" ,python-pytest)))
> +    (propagated-inputs
> +      `(("python-dnspython" ,python-dnspython)
> +        ("python-setproctitle" ,python-setproctitle)))
> +    (home-page
> +      "https://github.com/dlenski/vpn-slice")

Please avoid unnecessary newlines.

> +    (synopsis
> +      "Easy and secure split-tunnel VPN setup")

Likewise.

> +    (description
> +      "Minimize your contact with an intrusive VPN - split your traffic
> +between the VPN tunnel and your normal network interfaces")

The sentence lacks a subject and a period, and the single “-” should be
replaced by “---”, which is the proper Texinfo syntax.

I noticed that the README says

  It automatically looks up named hosts, using the VPN's DNS servers,
  and adds entries for them to your /etc/hosts

I don’t know about Guix System, but on NixOS /etc/hosts is read-only, so
this wouldn’t work.

> +    (license license:gpl3)))

‘LICENSE.txt’ says gpl3+.
Allan Adair Nov. 1, 2021, 2:04 p.m. UTC | #2
Any progress on approving or denying this patch? Just a user wanting to
use this package ☺
Vagrant Cascadian Sept. 1, 2023, 8:38 p.m. UTC | #3
On 2021-09-18, phodina wrote:
> +(define-public vpn-slice
> +  (package
> +    (name "vpn-slice")
> +    (version "0.15")

vpn-slice 0.16.1 was added in commit
79415548f7acc3afd8a79fb8ca5d103ad065a2bf.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 330a3271b4..4d49597564 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2021 Domagoj Stolfa <ds815@gmx.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Petr Hodina  <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -432,6 +433,31 @@  file for more details.")
            ;; src/libstrongswan/plugins/des/des_crypter.c
            license:bsd-4))))

+(define-public vpn-slice
+  (package
+    (name "vpn-slice")
+    (version "0.15")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "vpn-slice" version))
+        (sha256
+          (base32
+            "0lv3g1bq6ssz6fn6zlzn12dahc4d7nf7kjwxsnb5d7gdrfp36lbx"))))
+    (build-system python-build-system)
+    (native-inputs `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+      `(("python-dnspython" ,python-dnspython)
+        ("python-setproctitle" ,python-setproctitle)))
+    (home-page
+      "https://github.com/dlenski/vpn-slice")
+    (synopsis
+      "Easy and secure split-tunnel VPN setup")
+    (description
+      "Minimize your contact with an intrusive VPN - split your traffic
+between the VPN tunnel and your normal network interfaces")
+    (license license:gpl3)))
+
 (define-public vpnc
   (package
    (name "vpnc")