[bug#78513,core-packages-team,1/1] gnu: libxcrypt: Remove now unnecessary Hurd64 patch.

Message ID OQj6DaS--F-9@tutamail.com
State New
Headers
Series [bug#78513,core-packages-team,1/1] gnu: libxcrypt: Remove now unnecessary Hurd64 patch. |

Commit Message

yelninei--- via Guix-patches via May 20, 2025, 7:12 p.m. UTC
  Hello,

With this patch the bare-hurd64.tmpl os crossbuilds and runs on core-packages-team.

Haven't figured out how to make a proper 64bit childhurd to get the native packages building with the nice offloading setup.

I also managed to get the updated rumpkernel to build (the updated build.sh unsets C_INCLUDE_PATH, it also it depends on the new hurd lib libirqhelp which introduces a circular depency, for now i have created a separate package for it similar to hurd-minimal) .
However idk if this is something for core-packages-team? I guess it should be hurd-team but that has moved into core-packages-team?
  

Patch

From 57e36f535a691c4c9d8fdd41e7461cd711cf644a Mon Sep 17 00:00:00 2001
Message-ID: <57e36f535a691c4c9d8fdd41e7461cd711cf644a.1747767404.git.yelninei@tutamail.com>
In-Reply-To: <cover.1747767404.git.yelninei@tutamail.com>
References: <cover.1747767404.git.yelninei@tutamail.com>
From: Yelninei <yelninei@tutamail.com>
Date: Sun, 18 May 2025 11:41:44 +0100
Subject: [PATCH core-packages-team 1/1] gnu: libxcrypt: Remove now unnecessary
 Hurd64 patch.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/crypto.scm (libxcrypt)[arguments]: Remove
‘apply-hurd64-patch’ phase.
* gnu/packages/patches/libxcrypt-hurd64.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove it.

Change-Id: Id98b268426ef22219e2bfc5041e7d7965c5f9275
---
 gnu/local.mk                                |  1 -
 gnu/packages/crypto.scm                     | 10 ------
 gnu/packages/patches/libxcrypt-hurd64.patch | 38 ---------------------
 3 files changed, 49 deletions(-)
 delete mode 100644 gnu/packages/patches/libxcrypt-hurd64.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 7bd44a9776..bd17d816de 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1785,7 +1785,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/libutils-remove-damaging-includes.patch	\
   %D%/packages/patches/libvdpau-va-gl-unbundle.patch		\
   %D%/packages/patches/libvpx-CVE-2016-2818.patch		\
-  %D%/packages/patches/libxcrypt-hurd64.patch			\
   %D%/packages/patches/libxml2-xpath0-Add-option-xpath0.patch	\
   %D%/packages/patches/libwpd-gcc-compat.patch			\
   %D%/packages/patches/libxslt-generated-ids.patch		\
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 1828769b03..81f857a1b6 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1641,16 +1641,6 @@  (define-public libxcrypt
      (list perl))
     (arguments
      (cond
-       ((target-hurd64?)
-        (list
-          #:phases
-          #~(modify-phases %standard-phases
-              (add-after 'unpack 'apply-hurd64-patch
-                (lambda _
-                  (let ((patch
-                         #$(local-file
-                            (search-patch "libxcrypt-hurd64.patch"))))
-                    (invoke "patch" "--force" "-p1" "-i" patch)))))))
        ((target-ppc32?)
         (list #:tests? #f))     ; TODO: Investigate test failures.
        (else '())))
diff --git a/gnu/packages/patches/libxcrypt-hurd64.patch b/gnu/packages/patches/libxcrypt-hurd64.patch
deleted file mode 100644
index 9fc3018539..0000000000
--- a/gnu/packages/patches/libxcrypt-hurd64.patch
+++ /dev/null
@@ -1,38 +0,0 @@ 
-Upstream-status: Taken from upstream:
-    <https://github.com/besser82/libxcrypt/commit/b2c1da2e1ce2d3e72f511f5bc94a6ffa68b70917>
-
-From b2c1da2e1ce2d3e72f511f5bc94a6ffa68b70917 Mon Sep 17 00:00:00 2001
-From: Samuel Thibault <samuel.thibault@ens-lyon.org>
-Date: Sun, 14 Jul 2024 13:13:07 +0200
-Subject: [PATCH] Add binary compatibility for x86_64 GNU/Hurd
-Content-Transfer-Encoding: 8bit
-Content-Type: text/plain; charset=UTF-8
-
-
-diff --git a/lib/libcrypt.map.in b/lib/libcrypt.map.in
-index 88ea911..a56b7bf 100644
---- a/lib/libcrypt.map.in
-+++ b/lib/libcrypt.map.in
-@@ -43,5 +43,5 @@ fcrypt			-		GLIBC_2.0
- %chain GLIBC_2.0 GLIBC_2.2 GLIBC_2.2.1 GLIBC_2.2.2 GLIBC_2.2.5 GLIBC_2.2.6
- %chain GLIBC_2.3 GLIBC_2.4 GLIBC_2.12 GLIBC_2.16 GLIBC_2.17 GLIBC_2.18
- %chain GLIBC_2.21 GLIBC_2.27 GLIBC_2.29 GLIBC_2.32 GLIBC_2.33 GLIBC_2.35
--%chain GLIBC_2.36
-+%chain GLIBC_2.36 GLIBC_2.38
- %chain OW_CRYPT_1.0 XCRYPT_2.0 XCRYPT_4.3 XCRYPT_4.4
-diff --git a/lib/libcrypt.minver b/lib/libcrypt.minver
-index 8478077..c5a5bf2 100644
---- a/lib/libcrypt.minver
-+++ b/lib/libcrypt.minver
-@@ -51,6 +51,7 @@
- #VERSION     SYSTEM          CPU_FAMILY    PREPROCESSOR_CHECK
- 
- # GNU Hurd
-+GLIBC_2.38   gnu             x86_64
- GLIBC_2.2.6  gnu             i[3-9]86
- ERROR        gnu             .
- 
--- 
-Janneke Nieuwenhuizen <janneke@gnu.org>  | GNU LilyPond https://LilyPond.org
-Freelance IT https://www.JoyOfSource.com | Avatar® https://AvatarAcademy.com
-
-- 
2.49.0