[bug#78241,core-packages-team] Update Hurd and Mach

Message ID OQHsXpp--F-9@tutamail.com
State New
Headers
Series [bug#78241,core-packages-team] Update Hurd and Mach |

Commit Message

yelninei--- via Guix-patches via May 15, 2025, 7:39 a.m. UTC
  Hi,

Fixed in the attached patch. I'll try to get the rest of the core-packages-team fixes ready during the weekend

May 12, 2025, 16:54 by janneke@gnu.org:

> Hi,
>
>> Attached a patch to relax gcc-14 for rumpkernel for
>> core-packages-team. It might be not be needed with theĀ 20250111 tag
>> but I have not found the patience to look into updating it.
>>
>
> That's okay.
>
>> It overwrites HOST_CFLAGS which are -O by default. Let me know if you
>> want to add the -Wno-implicit-function-declaration instead of
>> replacing.
>>
>
> Yes, let's keep the explicit "-O" and could you also use
>
>  -Wno-error=implicit-function-declaration
>
> that way we'll keep seeing the warning as long as it's there.
>
> Thanks!  Greetings,
> Janneke
>
> -- 
> Janneke Nieuwenhuizen <janneke@gnu.org>  | GNU LilyPond https://LilyPond.org
> Freelance IT https://www.JoyOfSource.com | AvatarĀ® https://AvatarAcademy.com
>
  

Comments

Janneke Nieuwenhuizen May 15, 2025, 8:15 a.m. UTC | #1
> Fixed in the attached patch.

Thanks, pushed to core-packages-team.

> I'll try to get the rest of the
> core-packages-team fixes ready during the weekend

Great; Greeting,
Janneke
  

Patch

From 98565fd6e0718d0602b8ba3a0046a9c49cebf19f Mon Sep 17 00:00:00 2001
From: Yelninei <yelninei@tutamail.com>
Date: Fri, 9 May 2025 08:01:19 +0000
Subject: [PATCH] gnu: rumpkernel: Fix build with gcc-14.

* gnu/packages/hurd.scm (rumpkernel): Add -Wno-error=implicit-function-declaration
for the HOST_CC

Change-Id: I4e86cd9900b56a904190e217c21bcfa279c12a5a
---
 gnu/packages/hurd.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 1b2b6553a0..9802469c42 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -851,6 +851,9 @@  (define (noisy-setenv name value)
                            " -DNO_PCI_MSI_MSIX=yes"
                            " -DNUSB_DMA=1"
                            " -DPAE")
+                     "-V" (string-append
+                           "HOST_CFLAGS=-O"
+                           " -Wno-error=implicit-function-declaration")
                      "-V" (string-append
                            "CWARNFLAGS="
                            " -Wno-error=maybe-uninitialized"
-- 
2.49.0