diff mbox series

[bug#64113] gnu: Add missing native search paths to audio plugins.

Message ID ONHcOuPFGoTwxb69pm-sO_iF9YIL6bo4Nt43MYNRZciaPjhmcINgq_OUC1du2HiWTNmc7_sB77HvbBczm7ZCVR2o1NzAsjDxIwqR3uyas08=@proton.me
State New
Headers show
Series [bug#64113] gnu: Add missing native search paths to audio plugins. | expand

Commit Message

Sughosha June 16, 2023, 5:07 p.m. UTC
* gnu/packages/audio.scm: Add native-search-paths to autotalent,
caps-plugins-lv2, infamous-plugins, swh-plugins, swh-plugins-lv2, amb-plugins,
mcp-plugins, rev-plugins, fil-plugins, ste-plugins, vco-plugins, wah-plugins,
g2reverb, ladspa-bs2b, noise-repellent and lv2-speech-denoiser.
* gnu/packages/music.scm: Do the same to fluida-lv2, surge-synth, ninjas2,
bsequencer, bchoppr, bshapr, bjumblr, bschaffi, synthv1, drumkv1, samplv1,
padthv1, amsynth, paulxstretch, yoshimi, ams-lv2, synthpod, gx-guvnor-lv2,
gx-vbass-preamp-lv2, rkrlv2, mod-utilities, qmidiarp, liquidsfz, sfizz, fabla,
sorcer, artyfx, lsp-plugins, sherlock-lv2, foo-yc20, spectacle-analyzer,
x42-plugins, zam-plugins, geonkick, avldrums-lv2, helm, dragonfly-reverb,
zplugins, remid-lv2, vl1-emulator, regrader, fogpad, tap-lv2, wolf-shaper,
wolf-spectrum and shiru-lv2.
---
 gnu/packages/audio.scm |  64 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 gnu/packages/music.scm | 220 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 284 insertions(+)

--
libgit2 1.5.1

Comments

Maxim Cournoyer Sept. 2, 2023, 6:37 p.m. UTC | #1
Hello,

Sughosha <Sughosha@proton.me> writes:

> * gnu/packages/audio.scm: Add native-search-paths to autotalent,
> caps-plugins-lv2, infamous-plugins, swh-plugins, swh-plugins-lv2, amb-plugins,
> mcp-plugins, rev-plugins, fil-plugins, ste-plugins, vco-plugins, wah-plugins,
> g2reverb, ladspa-bs2b, noise-repellent and lv2-speech-denoiser.
> * gnu/packages/music.scm: Do the same to fluida-lv2, surge-synth, ninjas2,
> bsequencer, bchoppr, bshapr, bjumblr, bschaffi, synthv1, drumkv1, samplv1,
> padthv1, amsynth, paulxstretch, yoshimi, ams-lv2, synthpod, gx-guvnor-lv2,
> gx-vbass-preamp-lv2, rkrlv2, mod-utilities, qmidiarp, liquidsfz, sfizz, fabla,
> sorcer, artyfx, lsp-plugins, sherlock-lv2, foo-yc20, spectacle-analyzer,
> x42-plugins, zam-plugins, geonkick, avldrums-lv2, helm, dragonfly-reverb,
> zplugins, remid-lv2, vl1-emulator, regrader, fogpad, tap-lv2, wolf-shaper,
> wolf-spectrum and shiru-lv2.

It's best to keep changes self-contained *per package*, i.e. one commit
per package changed.

>  gnu/packages/audio.scm |  64 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>  gnu/packages/music.scm | 220 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>  2 files changed, 284 insertions(+)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 58a981b..564f6bf 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -1182,6 +1182,10 @@ (define-public autotalent
>               #t)))))
>      (inputs
>       (list ladspa))
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "LADSPA_PATH")
> +            (files '("lib/ladspa")))))

I think since these search paths appear to be reused often, they should
be defined in the (guix search-paths) modules for easy reuse.

>      (home-page "https://github.com/moddevices/caps-lv2")
>      (synopsis "LV2 port of the CAPS audio plugin collection")
>      (description
> @@ -1388,6 +1396,10 @@ (define-public infamous-plugins
>       (list cairo fftwf lv2 ntk zita-resampler))
>      (native-inputs
>       (list pkg-config))
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "LV2_PATH")
> +            (files '("lib/lv2")))))
>      (home-page "https://ssj71.github.io/infamousPlugins")
>      (synopsis "LV2 plugins for live use")
>      (description
> @@ -1453,6 +1465,10 @@ (define-public swh-plugins
>             which))
>      (inputs
>       (list fftwf perl-xml-parser))
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "LADSPA_PATH")
> +            (files '("lib/ladspa")))))
>      (build-system gnu-build-system)
>      (home-page "http://plugin.org.uk")
>      (synopsis "The SWH Plugins package for the LADSPA plugin system")
> @@ -1493,6 +1509,10 @@ (define-public swh-plugins-lv2
>       (list lv2 fftwf))
>      (native-inputs
>       (list libxslt pkg-config))
> +    (native-search-paths
> +     (list (search-path-specification
> +            (variable "LV2_PATH")
> +            (files '("lib/lv2")))))

You seem to be adding these search paths to *plugins*, which is
unexpected from my understanding: a plugins by itself does nothing; the
search paths should rather be defined on the consumer of the plugins
(e.g. Ardour), no?
Sughosha Nov. 1, 2023, 6:23 a.m. UTC | #2
Hi Maxim,

------- Original Message -------
Maxim Cournoyer <maxim.cournoyer@gmail.com> schrieb am Samstag, 2. September 2023 um 20:37:

> You seem to be adding these search paths to plugins, which is
> unexpected from my understanding: a plugins by itself does nothing; the
> search paths should rather be defined on the consumer of the plugins
> (e.g. Ardour), no?
> 
> --
> Thanks,
> Maxim

Oh yes. I think what you are saying is right. The search path should rather be defined on the consumer of the plugins, like Ardour and Qtractor. I read in this article, <https://guix.gnu.org/blog/2019/guix-profiles-in-practice/>, which asks to add man-db, info-reader or pkg-config to the profile manifest, so adding search path to every package with man pages does not make any sense. I think this issue can be closed now.

Thanks,
Sughosha.
Maxim Cournoyer Nov. 1, 2023, 7:28 p.m. UTC | #3
tags 64113 + notabug
thanks

Sughosha <Sughosha@proton.me> writes:

> Hi Maxim,
>
> ------- Original Message -------
> Maxim Cournoyer <maxim.cournoyer@gmail.com> schrieb am Samstag, 2. September 2023 um 20:37:
>
>> You seem to be adding these search paths to plugins, which is
>> unexpected from my understanding: a plugins by itself does nothing; the
>> search paths should rather be defined on the consumer of the plugins
>> (e.g. Ardour), no?
>> 
>> --
>> Thanks,
>> Maxim
>
> Oh yes. I think what you are saying is right. The search path should
> rather be defined on the consumer of the plugins, like Ardour and
> Qtractor. I read in this article,
> <https://guix.gnu.org/blog/2019/guix-profiles-in-practice/>, which
> asks to add man-db, info-reader or pkg-config to the profile manifest,
> so adding search path to every package with man pages does not make
> any sense. I think this issue can be closed now.

Thanks for the response.  Closing!
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 58a981b..564f6bf 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1182,6 +1182,10 @@  (define-public autotalent
              #t)))))
     (inputs
      (list ladspa))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "http://tombaran.info/autotalent.html")
     (synopsis "Pitch-correction LADSPA audio plugin")
     (description
@@ -1314,6 +1318,10 @@  (define-public caps-plugins-lv2
     (inputs
      (list lv2))
     ;; home-page of the original LADSPA version: http://quitte.de/dsp/caps.html
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/moddevices/caps-lv2")
     (synopsis "LV2 port of the CAPS audio plugin collection")
     (description
@@ -1388,6 +1396,10 @@  (define-public infamous-plugins
      (list cairo fftwf lv2 ntk zita-resampler))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://ssj71.github.io/infamousPlugins")
     (synopsis "LV2 plugins for live use")
     (description
@@ -1453,6 +1465,10 @@  (define-public swh-plugins
            which))
     (inputs
      (list fftwf perl-xml-parser))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (build-system gnu-build-system)
     (home-page "http://plugin.org.uk")
     (synopsis "The SWH Plugins package for the LADSPA plugin system")
@@ -1493,6 +1509,10 @@  (define-public swh-plugins-lv2
      (list lv2 fftwf))
     (native-inputs
      (list libxslt pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "http://plugin.org.uk")
     (synopsis "SWH plugins in LV2 format")
     (description
@@ -1768,6 +1788,10 @@  (define-public amb-plugins
                (("/usr/bin/install") (which "install"))
                (("/bin/rm") "#"))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA ambisonics plugins")
     (description
@@ -1805,6 +1829,10 @@  (define-public mcp-plugins
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "Chorus, phaser, and vintage high-pass and low-pass filters")
     (description
@@ -1845,6 +1873,10 @@  (define-public rev-plugins
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA reverb plugin")
     (description
@@ -1881,6 +1913,10 @@  (define-public fil-plugins
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA four-band parametric equalizer plugin")
     (description
@@ -1926,6 +1962,10 @@  (define-public ste-plugins
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA stereo width plugin")
     (description
@@ -1963,6 +2003,10 @@  (define-public vco-plugins
                (("/usr") (assoc-ref outputs "out"))
                (("/bin/cp") (which "cp")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA plugin for synthesizer oscillators")
     (description
@@ -2007,6 +2051,10 @@  (define-public wah-plugins
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA Autowah effect plugin")
     (description
@@ -2043,6 +2091,10 @@  (define-public g2reverb
              (substitute* "Makefile"
                (("/usr") (assoc-ref outputs "out")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://kokkinizita.linuxaudio.org")
     (synopsis "LADSPA stereo reverb plugin")
     (description
@@ -2774,6 +2826,10 @@  (define-public ladspa-bs2b
     (build-system gnu-build-system)
     (native-inputs (list pkg-config))
     (inputs (list ladspa libbs2b))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))))
     (home-page "https://sourceforge.net/projects/bs2b/")
     (synopsis "Bauer stereophonic-to-binaural DSP - LADSPA plugin")
     (description "The Bauer stereophonic-to-binaural DSP (bs2b) library and
@@ -4929,6 +4985,10 @@  (define-public noise-repellent
      (list lv2 fftwf))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/lucianodato/noise-repellent")
     (synopsis "LV2 plugin for broadband noise reduction")
     (description "Noise Repellent is an LV2 plugin to reduce noise.  It has
@@ -4996,6 +5056,10 @@  (define-public lv2-speech-denoiser
        (list lv2))
       (native-inputs
        (list autoconf automake libtool pkg-config))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "https://github.com/werman/noise-suppression-for-voice")
       (synopsis "Speech denoise LV2 plugin based on Xiph's RNNoise library")
       (description "RNNoise is a library that uses deep learning to apply
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2e7edda..d8e4e65 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1181,6 +1181,10 @@  (define-public fluida-lv2
     (list cairo libx11 lv2 fluidsynth))
    (native-inputs
     (list pkg-config))
+   (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
    (home-page "https://github.com/brummer10/Fluida.lv2")
    (synopsis "Fluidsynth as an LV2 audio plugin")
    (description "Fluida is an audio plugin in the LV2 format that acts as
@@ -1248,6 +1252,13 @@  (define-public surge-synth
           xcb-util-keysyms))
    (native-inputs
     (list pkg-config))
+   (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST3_PATH")
+            (files '("lib/vst3")))))
    (home-page "https://surge-synthesizer.github.io/")
    (synopsis "Synthesizer plugin")
    (description
@@ -1449,6 +1460,10 @@  (define-public ninjas2
            libsndfile))
     (native-inputs
      (list ladspa lv2 pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Sample slicer audio plugin")
     (description
      "Ninjas 2 is a rewrite of the Ninjas sample slicer audio plugin.
@@ -1947,6 +1962,10 @@  (define-public bsequencer
      (list cairo lv2 libx11))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/sjaehn/BSEQuencer")
     (synopsis "Multi-channel MIDI step sequencer LV2 plugin")
     (description
@@ -1968,6 +1987,10 @@  (define-public bchoppr
        (file-name (git-file-name name version))
        (sha256
         (base32 "1jfp98qa0frmdybrg71fn8wxn1b3ginkbkcg9cz9y83j1m0jqrif"))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Audio stream-chopping LV2 plugin")
     (description "B.Choppr cuts the audio input stream into a repeated
 sequence of up to 16 chops.  Each chop can be leveled up or down (gating).
@@ -1989,6 +2012,10 @@  (define-public bshapr
        (file-name (git-file-name name version))
        (sha256
         (base32 "1qr3fxqcplgb6iqi2vxc27jghhv6qsidww2by15zb2vs34yh73pl"))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Beat/envelope shaper LV2 plugin")
     (description "B.Shapr is a beat/envelope shaper LV2 plugin.")
     (home-page "https://github.com/sjaehn/BShapr")
@@ -2010,6 +2037,10 @@  (define-public bjumblr
         (base32 "00fgax8aqqggs54pjpagw5pc30kgxaghh8mrzpqwhs06cnchcam9"))))
     (inputs
      (list cairo libsndfile lv2))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Pattern-controlled audio stream/sample re-sequencer LV2 plugin")
     (description "B.Jumblr is a pattern-controlled audio stream / sample
 re-sequencer LV2 plugin.")
@@ -2036,6 +2067,10 @@  (define-public bschaffl
        ("libsndfile" ,libsndfile)
        ("libx11" ,libx11)
        ("lv2" ,lv2)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/sjaehn/BSchaffl")
     (synopsis "Pattern-controlled MIDI amp & time stretch LV2 plugin")
     (description "This package provides an LV2 plugin that allows for
@@ -2393,6 +2428,10 @@  (define-public synthv1
            qtsvg))
     (native-inputs
      (list pkg-config qttools))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://synthv1.sourceforge.io")
     (synopsis "Polyphonic subtractive synthesizer")
     (description
@@ -2426,6 +2465,10 @@  (define-public drumkv1
            qtsvg))
     (native-inputs
      (list pkg-config qttools))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://drumkv1.sourceforge.io")
     (synopsis "Drum-kit sampler synthesizer with stereo effects")
     (description
@@ -2459,6 +2502,10 @@  (define-public samplv1
            qtsvg))
     (native-inputs
      (list pkg-config qttools))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://samplv1.sourceforge.io")
     (synopsis "Polyphonic sampler synthesizer with stereo effects")
     (description
@@ -2492,6 +2539,10 @@  (define-public padthv1
            qtsvg))
     (native-inputs
      (list pkg-config qttools))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://padthv1.sourceforge.io")
     (synopsis "Polyphonic additive synthesizer")
     (description
@@ -2540,6 +2591,10 @@  (define-public amsynth
      (list gsettings-desktop-schemas))
     (native-inputs
      (list intltool pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://amsynth.github.io")
     (synopsis "Analog modeling synthesizer")
     (description
@@ -2624,6 +2679,13 @@  (define-public paulxstretch
                   libxext
                   libxinerama
                   libxrandr))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CLAP_PATH")
+            (files '("lib/clap")))
+           (search-path-specification
+            (variable "VST3_PATH")
+            (files '("lib/vst3")))))
     (supported-systems '("x86_64-linux")) ;pffft.c uses SIMD code
     (synopsis "Audio timestretching application and plugin")
     (description
@@ -3267,6 +3329,10 @@  (define-public yoshimi
            zlib))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://yoshimi.sourceforge.net/")
     (synopsis "Multi-paradigm software synthesizer")
     (description
@@ -3551,6 +3617,10 @@  (define-public ams-lv2
            lvtk))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/blablack/ams-lv2")
     (synopsis "Port of Alsa Modular Synth internal modules into LV2")
     (description "This set of LV2 plugins is a port of the internal modules
@@ -3704,6 +3774,10 @@  (define-public synthpod
            xcb-util-xrm
            zita-alsa-pcmi))
     (native-inputs (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://open-music-kontrollers.ch/lv2/synthpod/")
     (synopsis "Nonlinear LV2 plugin container")
     (description
@@ -4352,6 +4426,10 @@  (define-public gx-guvnor-lv2
              #t)))))
     (inputs
      (list lv2))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/brummer10/GxGuvnor.lv2")
     (synopsis "Overdrive/distortion pedal simulation")
     (description "This package provides the LV2 plugin \"GxGuvnor\", a
@@ -4380,6 +4458,10 @@  (define-public gx-vbass-preamp-lv2
        (list lv2 gtk+-2))
       (native-inputs
        (list pkg-config))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "https://github.com/brummer10/GxVBassPreAmp.lv2")
       (synopsis "Simulation of the Vox Venue Bass 100 Pre Amp Section")
       (description "This package provides the LV2 plugin \"GxVBassPreAmp\", a
@@ -4623,6 +4705,10 @@  (define-public rkrlv2
        (list fftw libsamplerate lv2))
       (native-inputs
        (list pkg-config))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "https://github.com/ssj71/rkrlv2")
       (synopsis "Rakarrack effects ported to LV2 plugins")
       (description "This package provides the Rakarrack effects as LV2
@@ -4659,6 +4745,10 @@  (define-public mod-utilities
            (delete 'configure))))
       (inputs
        (list lv2))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "https://github.com/moddevices/mod-utilities")
       (synopsis "LV2 utility plugins")
       (description "This package provides LV2 audio utility plugins, such as
@@ -4685,6 +4775,10 @@  (define-public qmidiarp
      (list qtbase-5 alsa-lib jack-1 liblo lv2))
     (native-inputs
      (list pkg-config qttools-5))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://qmidiarp.sourceforge.net/")
     (synopsis "MIDI arpeggiator")
     (description "QMidiArp is an advanced MIDI arpeggiator, programmable step
@@ -4915,6 +5009,10 @@  (define-public liquidsfz
      (list autoconf automake libtool pkg-config))
     (inputs
      (list jack-2 libsndfile lv2 readline))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://github.com/swesterfeld/liquidsfz")
     (synopsis "Sampler library")
     (description "The main goal of liquidsfz is to provide an SFZ sampler
@@ -4967,6 +5065,10 @@  (define-public sfizz
            libsamplerate
            pugixml
            simde))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://sfz.tools/sfizz/")
     (synopsis "SFZ parser and synth library")
     (description "Sfizz provides an SFZ parser and synth C++ library.  It
@@ -5393,6 +5495,10 @@  (define-public fabla
       (arguments '(#:tests? #f)) ;there are none
       (inputs (list ntk cairomm libsndfile))
       (native-inputs (list pkg-config lv2 mesa))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "http://openavproductions.com/fabla/")
       (synopsis "Sampler LV2 plugin")
       (description
@@ -5437,6 +5543,10 @@  (define-public sorcer
                          "-o" "main.cpp" "main.dsp")))))))
       (inputs (list boost lv2 ntk))
       (native-inputs (list faust-0.9.67 pkg-config))
+      (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
       (home-page "http://openavproductions.com/sorcer/")
       (synopsis "Wavetable LV2 plugin synth")
       (description "Sorcer is a wavetable LV2 plugin synthesizer, targeted at
@@ -5962,6 +6072,10 @@  (define-public artyfx
      (list cairo libsndfile))
     (native-inputs
      (list pkg-config lv2))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "http://openavproductions.com/artyfx/")
     (synopsis "Audio effect LV2 plugin bundle")
     (description "ArtyFX is an LV2 plugin bundle of artistic real-time audio
@@ -6013,6 +6127,16 @@  (define-public lsp-plugins
            mesa))
     (native-inputs
      (list pkg-config php))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))
+           (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))))
     (synopsis "Audio plugin collection")
     (description "LSP (Linux Studio Plugins) is a collection of audio
 plugins available as LADSPA/LV2 plugins and as standalone JACK
@@ -6039,6 +6163,10 @@  (define-public sherlock-lv2
      (list glu libx11 mesa sratom))
     (native-inputs
      (list flex pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Investigative LV2 plugin bundle")
     (description "The Sherlock plugin bundle contains LV2 plugins for
 visualizing LV2 atom, MIDI and OSC events.  They can be used for monitoring
@@ -6078,6 +6206,10 @@  (define-public foo-yc20
            lv2))
     (native-inputs
      (list faust pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://foo-yc20.codeforcode.com/")
     (synopsis "Implementation of Yamaha YC-20 combo organ from 1969")
     (description "This is a Faust implementation of a 1969 designed Yamaha
@@ -6122,6 +6254,10 @@  (define-public spectacle-analyzer
            jack-1
            lv2
            mesa))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Realtime graphical spectrum analyzer")
     (description "Spectacle is a real-time spectral analyzer using the
 short-time Fourier transform, available as LV2 audio plugin and JACK client.")
@@ -6171,6 +6307,10 @@  (define-public x42-plugins
            zita-convolver))
     (native-inputs
      (list help2man liblo lv2 font-dejavu pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Collection of LV2/JACK audio/MIDI processing plugins")
     (description "x42-plugins is a collection of over 80 cross-platform LV2
 audio and MIDI plugins that can also run as standalone JACK applications.")
@@ -6253,6 +6393,22 @@  (define-public zam-plugins
            zita-convolver))
     (native-inputs
      (list ladspa lv2 pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "CLAP_PATH")
+            (files '("lib/clap")))
+           (search-path-specification
+            (variable "LADSPA_PATH")
+            (files '("lib/ladspa")))
+           (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))
+           (search-path-specification
+            (variable "VST3_PATH")
+            (files '("lib/vst3")))))
     (synopsis "Collection of audio processing plugins")
     (description
      "Zam plugins is a collection of audio processing plugins in the LADSPA,
@@ -6293,6 +6449,10 @@  (define-public geonkick
            rapidjson))
     (native-inputs
      (list lv2 pkg-config sord))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Percussion synthesizer")
     (description "Geonkick is a synthesizer that can synthesize elements
 of percussion such as kicks, snares, hit-hats, shakers, claps and sticks.
@@ -6419,6 +6579,10 @@  (define-public avldrums-lv2
      (list cairo dssi glu mesa pango))
     (native-inputs
      (list pkg-config lv2))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://x42-plugins.com/x42/x42-avldrums")
     (synopsis "Drum sample player LV2 plugin dedicated to the AVLinux Drumkits")
     (description "AVLdrums is a drum sample player LV2 plugin dedicated to Glen
@@ -6475,6 +6639,13 @@  (define-public helm
            mesa))
     (native-inputs
      (list lv2 pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "LXVST_PATH")
+            (files '("lib/lxvst")))))
     (home-page "https://tytel.org/helm/")
     (synopsis "Polyphonic synth with lots of modulation")
     (description "Helm is a cross-platform polyphonic synthesizer available standalone
@@ -6665,6 +6836,10 @@  (define-public dragonfly-reverb
      (list pkg-config))
     (inputs
      (list jack-1 libx11 mesa))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (home-page "https://michaelwillis.github.io/dragonfly-reverb/")
     (synopsis "Concert hall reverb and room reverb effects")
     (description
@@ -6693,6 +6868,10 @@  (define-public zplugins
       (list guile-3.0 libsndfile lv2 ztoolkit-rsvg))
     (native-inputs
       (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis "Audio plugin collection")
     (description "ZPlugins is a collection of audio DSP plugins intended
 to be bundled with the Zrythm @dfn{digital audio workstation} (DAW).")
@@ -6721,6 +6900,10 @@  (define-public remid-lv2
     (native-inputs
      (list pkg-config))
     (home-page "https://github.com/ssj71/reMID.lv2")
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))))
     (synopsis
      "MIDI-controlled implementation of the SID 6581 chip used in the
 Commodore 64")
@@ -6761,6 +6944,13 @@  (define-public vl1-emulator
      (list cairo jack-1 mesa))
     (native-inputs
      (list pkg-config))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))))
     (home-page "https://github.com/linuxmao-org/VL1-emulator")
     (synopsis "Emulator of Casio VL-Tone VL1")
     (description "The VL1-Emulator is an emulator of Casio VL-Tone VL1,
@@ -6786,6 +6976,13 @@  (define-public regrader
        (sha256
         (base32
          "0gl4d5lf2afqknz22jz7hh7029sc9v1xrz6nbz9dlv42bwc0cvl0"))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))))
     (home-page "https://github.com/linuxmao-org/regrader")
     (synopsis "Delay effect plugin")
     (description
@@ -6811,6 +7008,13 @@  (define-public fogpad
        (sha256
         (base32
          "1j1hbya2dsqpf22zkpi4kwz3dram9g1ndxzmgfwpmf3i4jd3csgb"))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+            (files '("lib/lv2")))
+           (search-path-specification
+            (variable "VST2_PATH")
+            (files '("lib/vst")))))
     (home-page "https://github.com/linuxmao-org/fogpad")
     (synopsis "Reverb effect plugin")
     (description
@@ -6855,6 +7059,10 @@  (define-public tap-lv2
         (list lv2))
       (native-inputs
         (list pkg-config))
+      (native-search-paths
+       (list (search-path-specification
+              (variable "LV2_PATH")
+             (files '("lib/lv2")))))
       (synopsis "Audio plugin collection")
       (description "TAP (Tom's Audio Processing) plugins is a collection of
   audio effect plugins originally released as LADSPA plugins.  This package
@@ -6911,6 +7119,10 @@  (define-public wolf-shaper
      (list pkg-config))
     (inputs
       (list jack-1 lv2 mesa))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+           (files '("lib/lv2")))))
     (synopsis "Waveshaper plugin")
     (description "Wolf Shaper is a waveshaper plugin with a graph editor.
 It is provided as an LV2 plugin and as a standalone Jack application.")
@@ -6934,6 +7146,10 @@  (define-public wolf-spectrum
         (sha256
           (base32
             "17db1jlj7vb1xyvkdhhrsvdbwb7jqw6i4168cdvlj3yvn2ra8gpm"))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LV2_PATH")
+           (files '("lib/lv2")))))
     (synopsis "2D spectrogram plugin")
     (description "Wolf Spectrum is a real-time 2D spectrogram plugin.
 It is provided as an LV2 plugin and as a standalone Jack application.")
@@ -6996,6 +7212,10 @@  (define-public shiru-lv2
               lv2
               mesa
               pango))
+      (native-search-paths
+       (list (search-path-specification
+              (variable "LV2_PATH")
+              (files '("lib/lv2")))))
       (synopsis "Audio plugin collection")
       (description "Shiru plugins is a collection of audio plugins created
   by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin