[bug#72665] Add bitrot-plugins package

Message ID OLQ447Q--F-9@tuta.io
State New
Headers
Series [bug#72665] Add bitrot-plugins package |

Commit Message

Apoorv March 15, 2025, 6:32 p.m. UTC
  Here is the updated patch.

I could try to make dpf a separate package but pretty much every package that uses dpf as a submodule uses a different version/commit of it.
  

Patch

From 855135f15b6441f8803c307a16af47a14555c496 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Sun, 16 Mar 2025 00:00:12 +0530
Subject: [PATCH] Add bitrot-plugins package

Change-Id: I79233a736387d91dd432c47891df16850104dbfa
---
 gnu/packages/music.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index abe2ed0749..d7d899ce90 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -540,6 +540,34 @@  (define-public bespokesynth
 @end enumerate")
       (license license:gpl3))))
 
+(define-public bitrot-plugins
+  (let ((commit "06a72cd6cbe99b469e57a662cfb34e1cfe75e070")
+        (revision "0"))
+    (package
+      (name "bitrot-plugins")
+      (version (git-version "0.7" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/grejppi/bitrot")
+               (recursive? #t)
+               (commit commit)))
+         (sha256
+          (base32 "0gfhy6a1cc8czrw2bq922b87584fbzpvwdzrl0vv3acda03z1f85"))
+         (file-name (git-file-name name version))))
+      (build-system waf-build-system)
+      (arguments
+       (list
+        #:phases (modify-phases %standard-phases
+                   ;; no check target
+                   (delete 'check))))
+      (home-page "https://github.com/grejppi/bitrot")
+      (synopsis "Audio effect plugins (LV2, VST2, LADSPA) for glitch effects.")
+      (description "This is a collection of audio effect plugins
+(LV2, VST2, LADSPA) for glitch effects.")
+      (license license:asl2.0))))
+
 (define-public gxplugins-lv2
   (let ((commit "3a325270b99a41af5ca160e50278bd5469b697e8")
         (revision "0"))
-- 
2.48.1