[bug#72655] Add bespokesynth package

Message ID OLQ27YT--F-9@tuta.io
State New
Headers
Series [bug#72655] Add bespokesynth package |

Commit Message

Apoorv March 15, 2025, 6:24 p.m. UTC
  Here is the updated patch.
  

Patch

From bc8744a60b308751f7409316c15370847e02517d Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Mon, 24 Feb 2025 02:45:35 +0530
Subject: [PATCH] Add bespokesynth package definition

---
 gnu/packages/music.scm | 65 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 65 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7bbd1c0c9d..a25d94753e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -441,6 +441,71 @@  (define-public aria-maestosa
 score, keyboard, guitar, drum and controller views.")
     (license license:gpl3+)))
 
+(define-public bespokesynth
+  (let ((commit "1afd73ce4c374e6ff1dc9c750d1655dc7e12d79c")
+        (revision "1"))
+    (package
+      (name "bespokesynth")
+      (version (git-version "1.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/BespokeSynth/BespokeSynth")
+               (recursive? #t)
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1rwfvvhmqx7hwn7b4kn4cq357p827w596b1bwqjmlss5f4xzql34"))))
+      (inputs (list xcb-util-cursor
+                    xcb-util-keysyms
+                    xcb-util
+                    libxkbcommon
+                    libxcb
+                    gtk+
+                    webkitgtk-for-gtk3
+                    curl
+                    alsa-lib
+                    alsa-utils
+                    jack-2
+                    freetype
+                    libxinerama
+                    libxrandr
+                    mesa
+                    libxcursor
+                    libusb))
+      (native-inputs (list pkg-config
+                           python))
+      (build-system cmake-build-system)
+      (arguments
+       (list
+        #:tests? #f ;No test target available
+        #:build-type "Release"
+        #:phases
+        #~(modify-phases
+              %standard-phases
+            (add-after 'unpack 'pre-configure
+              (lambda _
+                ;; Override default location of fonts.conf.
+                (substitute* "libs/JUCE/modules/juce_graphics/native/juce_Fonts_linux.cpp"
+                  (("/usr/share/fonts/fonts.conf")
+                   "/run/current-system/profile/etc/fonts/fonts.conf")))))))
+      (home-page "http://bespokesynth.com/")
+      (synopsis "Software modular synth")
+      (description "Bespoke synth is software modular synththesizer.
+
+Some of the features include:
+
+@enumerate
+@item live-patchable environment, so you can build while the music is playing
+@item VST, VST3, LV2 hosting
+@item Python livecoding
+@item MIDI & OSC controller mapping
+@item Works on Windows, Mac, and Linux
+@end enumerate")
+      (license license:gpl3))))
+      (license license:gpl3))))
+
 (define-public libgpod
   (package
     (name "libgpod")
-- 
2.48.1