[bug#72637] Add airwindows-lv2 package

Message ID OLQ1mz7--F-9@tuta.io
State New
Headers
Series [bug#72637] Add airwindows-lv2 package |

Commit Message

Apoorv March 15, 2025, 6:22 p.m. UTC
  Here is the updated patch.
  

Patch

From 8c5a10795db299a7c68bb218c62d55ef1e8a28e9 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Mon, 24 Feb 2025 15:30:10 +0530
Subject: [PATCH] Add airwindows-lv2 package definition

---
 gnu/packages/music.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a25d94753e..ea5f4ea939 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -441,6 +441,41 @@  (define-public aria-maestosa
 score, keyboard, guitar, drum and controller views.")
     (license license:gpl3+)))
 
+(define-public airwindows-lv2
+  (let ((commit "82a5ade16b7cabdff14f7d8dc46bfd5a743b5eb2")
+        (revision "1"))
+    (package
+      (name "airwindows-lv2")
+      (version (git-version "30.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://git.sr.ht/~hannes/airwindows-lv2/")
+               (commit commit)))
+         (sha256
+          (base32 "06ga23qnl734cahlsqsc4gby7y36fdsw62g5xq5wz0asz3dl2smx"))
+         (file-name (git-file-name name version))))
+      (build-system meson-build-system)
+      (inputs (list lv2))
+      (native-inputs (list pkg-config))
+      (home-page "https://www.airwindows.com/")
+      (synopsis "LV2 port of Airwindows plugins")
+      (description
+       "This is an LV2 port of the Airwindows plugins
+originally created by Chris Johnson.
+
+Some of the well known plugins includes,
+@enumerate
+@item Console, A tone shaping plugin used in busses and channels
+@item DeBess, A Desser used removing esses from audio
+@item Galactic, A reverb plugin great for pads and ambient sounds
+@item Pressure, A compressor plugin
+@item ToTape, A analog tape emulation plugin
+@item Verbity, Another reverb plugin
+@end enumerate")
+      (license license:expat))))
+
 (define-public bespokesynth
   (let ((commit "1afd73ce4c374e6ff1dc9c750d1655dc7e12d79c")
         (revision "1"))
-- 
2.48.1