diff mbox series

[bug#59759] gnu: Add hydra.

Message ID OIsD2OrTJhOUcNNeSkgIGGBUJxya_gPawdyY7fIGWFrNYeQdUV8IFYtB0EZ2c9_TZDVwNajr1ywf8CB0ZQvRvcoOr69F2NB5rbyBLgic-5A=@protonmail.com
State New
Headers show
Series [bug#59759] gnu: Add hydra. | expand

Commit Message

phodina Jan. 8, 2023, 11:56 p.m. UTC
Hi Ludo’,

thanks for the review. Here's updated patch. 

Regarding the github tarball checksum I encountered this in some other patch and review discussion. So I'll stick with git-fetch in new and updated patches :-)

Comments

Ludovic Courtès Jan. 12, 2023, 10:31 p.m. UTC | #1
phodina <phodina@protonmail.com> skribis:

> From 1d23cf1460d701b96ab28feb980876540aca40dd Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 24 Feb 2022 19:29:14 +0100
> Subject: [PATCH v2] gnu: Add hydra.
>
> * gnu/packages/password-utils.scm (hydra): New variable.

Fixed a couple of typos and applied, thanks!

Ludo’.
diff mbox series

Patch

From 1d23cf1460d701b96ab28feb980876540aca40dd Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 24 Feb 2022 19:29:14 +0100
Subject: [PATCH v2] gnu: Add hydra.

* gnu/packages/password-utils.scm (hydra): New variable.

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 410c92d268..7de53cc6a4 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -67,6 +68,7 @@  (define-module (gnu packages password-utils)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aidc)
@@ -103,6 +105,7 @@  (define-module (gnu packages password-utils)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages rdesktop)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages ruby)
   #:use-module (gnu packages security-token)
@@ -1348,6 +1351,35 @@  (define-public hashcat-utils
 group them into chains.")
     (license license:expat)))
 
+(define-public hydra
+  (package
+    (name "hydra")
+    (version "9.4")
+    (home-page "https://github.com/vanhauser-thc/thc-hydra")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0dbx7yaqf4nl63pi8wmr19cxnp5v4w7fsd369krdy8hlc8k0qjgr"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ;no test suite
+       #:make-flags (list (string-append "CC="
+                                         ,(cc-for-target)))))
+    (native-inputs (list pkg-config))
+    (inputs (list freerdp gtk+ openssl zlib))
+    (synopsis "Gain acces to a remote sustem by trying logins and passwords")
+    (description
+     "This package provides a tool to demonstrate how esay it is to gain
+unauthorized access to a system by automatically attempting logins
+and passwords.  It supports a wide range of protocols including SSH, SMTP
+and HTTP.")
+    (license license:agpl3+)))
+
 (define-public bruteforce-luks
   (package
     (name "bruteforce-luks")
-- 
2.38.1