diff mbox series

[bug#72656] Add gxplugins-lv2 package

Message ID O4Pkod_--3-9@tuta.io
State New
Headers show
Series [bug#72656] Add gxplugins-lv2 package | expand

Commit Message

Apoorv Aug. 16, 2024, 10:37 a.m. UTC
This is a patch to add a new package, `gxplugins-lv2` to `gnu/packages/music.scm`.
diff mbox series

Patch

From a82cde2c78487606a125faf76c3d57fa3aecdc1d Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Fri, 16 Aug 2024 15:30:09 +0530
Subject: [PATCH 03/13] Add gxplugins-lv2 package

---
 gnu/packages/music.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7a4b272013..f827c5b605 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8081,6 +8081,43 @@  (define-public bespokesynth
      (description "Software modular synth")
      (license license:gpl3))))
 
+(define-public gxplugins-lv2
+  (let ((commit "3a325270b99a41af5ca160e50278bd5469b697e8")
+        (revision "0"))
+    (package
+     (name "gxplugins-lv2")
+     (version (git-version "1.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/brummer10/GxPlugins.lv2")
+             (recursive? #t)
+             (commit commit)))
+       (sha256
+        (base32 "1w7fsw97grc6zy1wv16kjgxbbs94a82g3kd6g1lvdpwl78nb2b59"))
+       (file-name (git-file-name name version))))
+     (build-system gnu-build-system)
+     (arguments
+      `(#:make-flags
+        (list
+         (string-append "INSTALL_DIR=" (assoc-ref %outputs "out") "/lib/lv2")
+         "CC=gcc")
+        #:phases (modify-phases %standard-phases
+                                ;; no configure target
+                                (delete 'configure))))
+     (native-inputs (list lv2
+                          libx11
+                          cairo
+                          cmake
+                          pkg-config))
+     (home-page "https://github.com/brummer10/GxPlugins.lv2")
+     (synopsis "A set of extra lv2 plugins from the guitarix project.")
+     (description
+      "GxPlugins.lv2 is a set of extra standalone lv2 plugins designed to compliment the Guitarix project.
+Each plugin exists as its own submodule under this repository.")
+     (license license:gpl3))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
-- 
2.45.2