diff mbox series

[bug#72637] Add airwindows-lv2 package

Message ID O4KFqEo--3-9@tuta.io
State New
Headers show
Series [bug#72637] Add airwindows-lv2 package | expand

Commit Message

Apoorv Aug. 15, 2024, 8:59 a.m. UTC
This is a patch to add a new package, `airwindows-lv2` to `gnu/packages/music.scm`. 

This is my first patch to add new package, let me know if I have to move or edit this definition for any reason.
diff mbox series

Patch

From c1f3b91ff4c92ed112f38476e831e582de0a153d Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Thu, 15 Aug 2024 14:25:48 +0530
Subject: [PATCH] Add airwindows-lv2 package

---
 gnu/packages/music.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 100a41f87b..0b418fa7a7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -8004,6 +8004,30 @@  (define-public le-biniou
 visuals based on audio performances or existing tracks.")
     (license license:gpl2+)))
 
+(define-public airwindows-lv2
+  (let ((commit "fa42cf2804402a562fb103654bbc7b20c84b50ee")
+        (revision "0"))
+    (package
+     (name "airwindows-lv2")
+     (version (git-version "28.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~hannes/airwindows-lv2/")
+             (commit commit)))
+       (sha256
+        (base32 "1hysxddg9c8c2nqbg430mdsqkqfk8jv3rasxn1nwpxx7s1sa8rfl"))
+       (file-name (git-file-name name version))))
+     (build-system meson-build-system)
+     (inputs (list lv2))
+     (native-inputs (list cmake pkg-config))
+     (home-page "https://www.airwindows.com/")
+     (synopsis "LV2 port of Airwindows plugins")
+     (description
+      "This is an LV2 port of the Airwindows plugins originally created by Chris Johnson.")
+     (license license:expat))))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar
-- 
2.45.2