diff mbox series

[bug#54432] gnu: rtl8812au-aircrack-ng-linux-module: Update to 37e27f9.

Message ID O2UmIjgVc6Yo_pLmrPfGr7LqIAeCiglHW3gqlWTfArPChZqNOh2LVadtUHGgKFJHvEt7K3RktfMx6vEfm0hnMU5u49tHEgG63JSc6fCQ3ic=@protonmail.com
State Accepted
Headers show
Series [bug#54432] gnu: rtl8812au-aircrack-ng-linux-module: Update to 37e27f9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

J. Sims March 17, 2022, 1:12 a.m. UTC
This fixes issues with Linux 5.17 and adds optimizations for 5.15:

https://github.com/aircrack-ng/rtl8812au/pull/942
https://github.com/aircrack-ng/rtl8812au/commit/2f52f84096ae09d36012d455d29b73e6cb37f740

It also runs `guix style`.

* gnu/packages/linux.scm (rtl8812au-aircrack-ng-linux-module):
Update to commit 37e27f9.
---
 gnu/packages/linux.scm | 33 ++++++++++++++-------------------
 1 file changed, 14 insertions(+), 19 deletions(-)

--
2.34.0

Comments

Liliana Marie Prikler March 17, 2022, 3:05 p.m. UTC | #1
Hi,

Am Donnerstag, dem 17.03.2022 um 01:12 +0000 schrieb J. Sims:
> This fixes issues with Linux 5.17 and adds optimizations for 5.15:
> 
> https://github.com/aircrack-ng/rtl8812au/pull/942
> https://github.com/aircrack-ng/rtl8812au/commit/2f52f84096ae09d36012d455d29b73e6cb37f740
> 
> It also runs `guix style`.
> 
> * gnu/packages/linux.scm (rtl8812au-aircrack-ng-linux-module):
> Update to commit 37e27f9.
> ---
>  gnu/packages/linux.scm | 33 ++++++++++++++-------------------
>  1 file changed, 14 insertions(+), 19 deletions(-)
> 
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index 0dc5c8260e..a49443bb3d 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -1383,29 +1383,24 @@ (define-public rtl8821ce-linux-module
>        (license license:gpl2))))
> 
>  (define-public rtl8812au-aircrack-ng-linux-module
> -  (let ((commit "307d694076b056588c652c2bdaa543a89eb255d9")
> -        (revision "6"))
> +  (let ((commit "37e27f9165300c89607144b646545fac576ec510")
> (revision "7"))
This indentation fix should not have been done.  Bad `guix style'.
>      (package
>        (inherit rtl8821ce-linux-module)
>        (name "rtl8812au-aircrack-ng-linux-module")
>        (version (git-version "5.6.4.2" revision commit))
> -      (source
> -       (origin
> -         (method git-fetch)
> -         (uri (git-reference
> -               (url "https://github.com/aircrack-ng/rtl8812au")
> -               (commit commit)))
> -         (file-name (git-file-name name version))
> -         (sha256
> -          (base32
> "1g2zga7jqzp4azwqpgxxx3lg07ijaaqw3zqnaa3i2brycwlnf8l9"))
> -         (modules '((guix build utils)))
> -         (snippet
> -          #~(begin
> -              ;; Remove bundled tarballs, APKs, word lists,
> speadsheets,
> -              ;; and other unnecessary unlicenced things.
> -              (for-each delete-file-recursively (list "android"
> -                                                      "docs"
> -                                                      "tools"))))))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url
> "https://github.com/aircrack-ng/rtl8812au")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                 
> "09n814pa6i0b0xkgssymcmbcdic05y9z5bsr6sxjfs40wawsk6af"))
> +                (modules '((guix build utils)))
> +                (snippet #~(begin
> +                             (for-each delete-file-recursively
> +                                       (list "android" "docs"
> "tools"))))))
The comment regarding what has been removed ought to be preserved. 
Other than that fair enough.
Leo Famulari March 17, 2022, 9:43 p.m. UTC | #2
On Thu, Mar 17, 2022 at 01:12:33AM +0000, J. Sims via Guix-patches via wrote:
> This fixes issues with Linux 5.17 and adds optimizations for 5.15:
> 
> https://github.com/aircrack-ng/rtl8812au/pull/942
> https://github.com/aircrack-ng/rtl8812au/commit/2f52f84096ae09d36012d455d29b73e6cb37f740
> 
> It also runs `guix style`.
> 
> * gnu/packages/linux.scm (rtl8812au-aircrack-ng-linux-module):
> Update to commit 37e27f9.

Thanks for paying attention to this package!

I pushed the update as commit a28dd4719267914482ee88250a2a6dfbdd81eca7,
although I did omit the style changes in light of Liliana's comments.

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=a28dd4719267914482ee88250a2a6dfbdd81eca7

We can use `guix style` but I prefer that we do it in its own commit,
and maybe even on the entire gnu/packages/linux.scm module at once.

That will make it easier to hide purely stylistic changes from `git
blame`, improving long-term utility of the Git history.

And as Liliana pointed out, maybe `guix style` needs some tweaks before
we use it here.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0dc5c8260e..a49443bb3d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1383,29 +1383,24 @@  (define-public rtl8821ce-linux-module
       (license license:gpl2))))

 (define-public rtl8812au-aircrack-ng-linux-module
-  (let ((commit "307d694076b056588c652c2bdaa543a89eb255d9")
-        (revision "6"))
+  (let ((commit "37e27f9165300c89607144b646545fac576ec510") (revision "7"))
     (package
       (inherit rtl8821ce-linux-module)
       (name "rtl8812au-aircrack-ng-linux-module")
       (version (git-version "5.6.4.2" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/aircrack-ng/rtl8812au")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1g2zga7jqzp4azwqpgxxx3lg07ijaaqw3zqnaa3i2brycwlnf8l9"))
-         (modules '((guix build utils)))
-         (snippet
-          #~(begin
-              ;; Remove bundled tarballs, APKs, word lists, speadsheets,
-              ;; and other unnecessary unlicenced things.
-              (for-each delete-file-recursively (list "android"
-                                                      "docs"
-                                                      "tools"))))))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/aircrack-ng/rtl8812au")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "09n814pa6i0b0xkgssymcmbcdic05y9z5bsr6sxjfs40wawsk6af"))
+                (modules '((guix build utils)))
+                (snippet #~(begin
+                             (for-each delete-file-recursively
+                                       (list "android" "docs" "tools"))))))
       (supported-systems '("x86_64-linux" "i686-linux"))
       (home-page "https://github.com/aircrack-ng/rtl8812au")
       (synopsis "Linux driver for Realtek USB wireless network adapters")