diff mbox series

[bug#50661,v2] gnu: Add valeronoi.

Message ID NxytQPoXMo3dJwVnfE3VBcmyZDccUmTF19s4_y6nLNQIq_NB4lCIi43s1dlC_dO_oOotYMGdAUgBq5kIsESEnyLD7INugwg7wg0heE9iv38=@protonmail.com
State Accepted
Headers show
Series [bug#50661,v2] gnu: Add valeronoi. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 1:37 p.m. UTC
Fixed forgotten formatting issues.

--8<---------------cut here---------------start------------->8--

* gnu/packages/engineering.scm (valeronoi): New variable.

--
2.32.0

Comments

Xinglu Chen Sept. 22, 2021, 4:27 p.m. UTC | #1
On Sat, Sep 18 2021, phodina via Guix-patches via wrote:

> Fixed forgotten formatting issues.
>
> --8<---------------cut here---------------start------------->8--
>
> * gnu/packages/engineering.scm (valeronoi): New variable.
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 46622f3a1f..f61fa04a43 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -24,6 +24,7 @@
>  ;;; Copyright © 2021 qblade <qblade@protonmail.com>
>  ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
>  ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -127,6 +128,7 @@
>    #:use-module (gnu packages xml)
>    #:use-module (gnu packages xiph)
>    #:use-module (gnu packages openkinect)
> +  #:use-module (gnu packages xdisorg)
>    #:use-module (gnu packages xorg))
>
>  (define-public librecad
> @@ -1168,6 +1170,42 @@ educational use.  As such, there is an emphasis on capabilities that improve
>  the 'showing the effect of'-style of operation.")
>      (license license:gpl2+)))
>
> +(define-public valeronoi
> +(package
> +  (name "valeronoi")
> +  (version "v0.1.3")

The version string should not contain the “v”, and the latest version
seems to be 0.1.4.

> +  (source (origin
> +            (method git-fetch)
> +            (uri
> +             (git-reference
> +              (url "https://github.com/ccoors/Valeronoi")
> +              (commit version)))
> +            (file-name (git-file-name name version))
> +            (sha256
> +             (base32
> +              "1a866h37xmhrnl7hnkhdzjjm8dpjwhq0va2g6hdcp7y949d82ipp"))))
> +  (build-system cmake-build-system)
> +  (arguments
> +    `(#:phases
> +      (modify-phases %standard-phases
> +       (replace 'check
> +        (lambda* (#:key outputs #:allow-other-keys)
> +         (invoke "./valeronoi-tests"))))))

The ‘outputs’ argument isn’t used, and the ‘check’ phase doesn’t respect
the ‘--without-tests’ package transformation.  The following snippet
would fix this.

  (lambda* (#:key tests? #:allow-other-keys)
    (when tests?
      (invoke "./valeronoi-tests")))

> +  (inputs `(("qtbase" ,qtbase-5)
> +            ("qtsvg" ,qtsvg)
> +            ("openssl" ,openssl)
> +            ("libxkbcommon" ,libxkbcommon)
> +            ("cgal" ,cgal)
> +            ("gmp" ,gmp)
> +            ("mpfr" ,mpfr)
> +            ("boost" ,boost)))
> +  (synopsis "WiFi mapping companion app for Valetudo")
> +  (description "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo
> +for generating WiFi signal strength maps.  It visualizes them using a Voronoi
> +diagram.")
> +  (home-page "https://github.com/ccoors/Valeronoi")
> +  (license license:gpl3)))

The ‘COPYING’ file says gpl3+.
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 46622f3a1f..f61fa04a43 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -24,6 +24,7 @@ 
 ;;; Copyright © 2021 qblade <qblade@protonmail.com>
 ;;; Copyright © 2021 Gerd Heber <gerd.heber@gmail.com>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -127,6 +128,7 @@ 
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages openkinect)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg))

 (define-public librecad
@@ -1168,6 +1170,42 @@  educational use.  As such, there is an emphasis on capabilities that improve
 the 'showing the effect of'-style of operation.")
     (license license:gpl2+)))

+(define-public valeronoi
+(package
+  (name "valeronoi")
+  (version "v0.1.3")
+  (source (origin
+            (method git-fetch)
+            (uri
+             (git-reference
+              (url "https://github.com/ccoors/Valeronoi")
+              (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "1a866h37xmhrnl7hnkhdzjjm8dpjwhq0va2g6hdcp7y949d82ipp"))))
+  (build-system cmake-build-system)
+  (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+       (replace 'check
+        (lambda* (#:key outputs #:allow-other-keys)
+         (invoke "./valeronoi-tests"))))))
+  (inputs `(("qtbase" ,qtbase-5)
+            ("qtsvg" ,qtsvg)
+            ("openssl" ,openssl)
+            ("libxkbcommon" ,libxkbcommon)
+            ("cgal" ,cgal)
+            ("gmp" ,gmp)
+            ("mpfr" ,mpfr)
+            ("boost" ,boost)))
+  (synopsis "WiFi mapping companion app for Valetudo")
+  (description "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo
+for generating WiFi signal strength maps.  It visualizes them using a Voronoi
+diagram.")
+  (home-page "https://github.com/ccoors/Valeronoi")
+  (license license:gpl3)))
+
 (define-public volk
   (package
     (name "volk")