diff mbox series

[bug#70233] Update emacs-lsp-mode to 9.0.0

Message ID Num9s9x-0--9@tuta.io
State New
Headers show
Series [bug#70233] Update emacs-lsp-mode to 9.0.0 | expand

Commit Message

Apoorv April 6, 2024, 6:49 a.m. UTC
lsp-mode got a update recently https://github.com/emacs-lsp/lsp-mode/releases/tag/9.0.0, which fixes this issue  that I was facing. So I am sharing a patch for the update.

Comments

Nicolas Goaziou April 6, 2024, 3:10 p.m. UTC | #1
Hello,

Apoorv via Guix-patches via <guix-patches@gnu.org> writes:

> lsp-mode got a update recently
> https://github.com/emacs-lsp/lsp-mode/releases/tag/9.0.0, which fixes
> this issue  that I was facing. So I am sharing a patch for the update.

Thank you.

I used the "9.0.0" tag instead of a random commit hash, and normalized
commit message.

Applied!

Regards,
diff mbox series

Patch

From 58b41a21ec3c6e3a09e869183141c17ba83c69d5 Mon Sep 17 00:00:00 2001
From: apoorv569 <apoorvs569@gmail.com>
Date: Sat, 6 Apr 2024 11:56:52 +0530
Subject: [PATCH] Update emacs-lsp-mode to 9.0.0

---
 gnu/packages/emacs-xyz.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 864889b51f..f5c169b60d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30677,11 +30677,11 @@  (define-public emacs-dockerfile-mode
     (license license:asl2.0)))
 
 (define-public emacs-lsp-mode
-  (let ((commit "26c4d3e54ad2956623e64132312fe864274d346f")
+  (let ((commit "0f85b3854de0b1f54fbbbdbd542fb2fe72d1dbe6")
         (revision "1"))
     (package
       (name "emacs-lsp-mode")
-      (version (git-version "8.0.1" revision commit))
+      (version (git-version "9.0.0" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -30690,7 +30690,7 @@  (define-public emacs-lsp-mode
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0klnik69b5y6s2q00vyshxymlg7k4x9x6m7wpsf7z9w12qn27alx"))))
+          (base32 "1njf76b67n7pqihfyj6749ib8p885wfmjkxj2ilsvqhd2xkzk95q"))))
       (build-system emacs-build-system)
       (arguments
        `(#:emacs ,emacs                 ;need libxml support
-- 
2.41.0