diff mbox series

[bug#48314,v3] Install guix system on Raspberry Pi

Message ID NahlaZknYPJe6yty_Ivn-Wj6I65H9wNMtiD8-4pz5q6e8lten7MrpPxpotIlQ2u0QgVf3V-gAHOHYw3H-ZzRmU2NN5em5vSOruAT8Dc7uxc=@protonmail.com
State New
Headers show
Series [bug#48314,v3] Install guix system on Raspberry Pi | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina April 14, 2022, 3:53 p.m. UTC
>
> > I've also attempted to cross-compile the system (from x86_64) but
> > there is at least one package that can't be build - guile-fibers-
> > 1.1.0. I've attached the build log as well.
>
>
> This one should now be fixed by
>
> 1f82602153 gnu: guile-fibers@1.1: Support cross-compilation.
>
> Greetings,
> Maxime.

Yes,

guile-fibers are now fixed, but the cross compile build fails now on shepherd-0.9 due to guile-fibers not being available.

Also the NTP requires this configure flag.


----
Petr

Comments

M April 14, 2022, 5:33 p.m. UTC | #1
phodina schreef op do 14-04-2022 om 15:53 [+0000]:
> Yes,
> 
> guile-fibers are now fixed, but the cross compile build fails now on
> shepherd-0.9 due to guile-fibers not being available.

Possibly the problem is just that guile-fibers is only in 'inputs' and
not 'native-inputs' -- due to how compilation and the module system
works in Guile, they need to be in both.

Greetings,
Maxime.
Ludovic Courtès April 15, 2022, 5:17 p.m. UTC | #2
Hi,

phodina <phodina@protonmail.com> skribis:

> guile-fibers are now fixed, but the cross compile build fails now on shepherd-0.9 due to guile-fibers not being available.

Fixed as suggested by Maxime in commit
6e174c4edd4786d93c1e424c45052f70b2bb3fb0.

Let us know what the next issue is.  :-)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 7a3c033b2e..cb90432730 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -153,7 +153,8 @@  (define-public ntp
             `(("libcap" ,libcap))
             '())))
    (arguments
-    `(#:phases
+    `(#:configure-flags (list "--with-yielding-select=yes")
+      #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'disable-network-test
                    (lambda _