diff mbox series

[bug#40757] New package: VisiData

Message ID NE_-mIBWQF-dqC5Te0zY6czGH4EZEpTtaiazpp6nx5DX1gFzpgn3vdwWNHnF2YxTj3VbxuhGFji-k9rD6n3TMvb4C73EeJ51hRJJHb-ph08=@protonmail.com
State Accepted
Headers show
Series [bug#40757] New package: VisiData | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

iyzsong--- via Guix-patches via April 22, 2020, 8:24 p.m. UTC
Hi Jack,

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Wednesday, April 22, 2020 3:53 PM, Jack Hill <jackhill@jackhill.us> wrote:


> I'm not an expert reviewer, but I'd like to try to help by offering the
> following suggestions for improvement.

Thank you for these suggestions! I've attached an updated version of the patch.

Ryan

Comments

Jack Hill April 22, 2020, 9:03 p.m. UTC | #1
On Wed, 22 Apr 2020, Ryan Prior via Guix-patches via wrote:

> Hi Jack,
>
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
> On Wednesday, April 22, 2020 3:53 PM, Jack Hill <jackhill@jackhill.us> wrote:
>
>
>> I'm not an expert reviewer, but I'd like to try to help by offering the
>> following suggestions for improvement.
>
> Thank you for these suggestions! I've attached an updated version of the patch.

You're welcome, and thanks for sending the updated patch.

I think now we're waiting on a more experienced reviewer to see if I 
missed anything, and if it looks good a committer to push your patch.

Best,
Jack
diff mbox series

Patch

From 5649ec22097278193426474b9a2f460cc3a931e0 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Tue, 21 Apr 2020 16:56:42 -0500
Subject: [PATCH] gnu: Add visidata.

* gnu/packages/visidata.scm (visidata): New variable.
---
 gnu/local.mk              |  2 ++
 gnu/packages/visidata.scm | 61 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 63 insertions(+)
 create mode 100644 gnu/packages/visidata.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index e70715000a..0cf64063c8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -31,6 +31,7 @@ 
 # Copyright © 2020 R Veera Kumar <vkor@vkten.in>
 # Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
 # Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+# Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 #
 # This file is part of GNU Guix.
 #
@@ -521,6 +522,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/video.scm			\
   %D%/packages/vim.scm				\
   %D%/packages/virtualization.scm		\
+  %D%/packages/visidata.scm                     \
   %D%/packages/vnc.scm				\
   %D%/packages/vpn.scm				\
   %D%/packages/vulkan.scm			\
diff --git a/gnu/packages/visidata.scm b/gnu/packages/visidata.scm
new file mode 100644
index 0000000000..9647b49289
--- /dev/null
+++ b/gnu/packages/visidata.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages visidata)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages python-science)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages time)
+  #:use-module (gnu packages xml)
+  #:use-module (guix build-system python)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public visidata
+  (package
+   (name "visidata")
+   (version "1.5.2")
+   (source (origin
+            (method url-fetch)
+            (uri (pypi-uri "visidata" version))
+            (sha256 (base32 "10adfyn4gkisvciqawgh2lakkhhnjjxiyp7mzbgcwkq1b3sigpf1"))))
+   (build-system python-build-system)
+   ;; Tests disabled because they are not packaged with the source tarball.
+   ;; Upstream suggests tests will be packaged with tarball around 2.0 release.
+   (arguments '(#:tests? #f))
+   (inputs
+    `(("python-dateutil" ,python-dateutil)
+      ("python-fonttools" ,python-fonttools)
+      ("python-h5py" ,python-h5py)
+      ("python-lxml" ,python-lxml)
+      ("python-openpyxl" ,python-openpyxl)
+      ("python-psycopg2" ,python-psycopg2)
+      ("python-pyyaml" ,python-pyyaml)
+      ("python-requests" ,python-requests)
+      ("python-xlrd" ,python-xlrd)
+      ("python-pandas" ,python-pandas)))
+   (synopsis "Terminal spreadsheet multitool for discovering and arranging data")
+   (description
+    "VisiData is an interactive multitool for tabular data.  It combines the
+clarity of a spreadsheet, the efficiency of the terminal, and the power of
+Python, into a lightweight utility which can handle millions of rows.")
+   (home-page "https://www.visidata.org/")
+   (license (list license:gpl3
+                  license:expat)))) ;; visidata/vdtui.py
-- 
2.17.1