diff mbox series

[bug#51920,v2] gnu: Add inkbox.

Message ID NCF2zYBerE1Ibq2YeTw53q8Z5PNPR4-2Rc6f5SigQwQJ9i_6LoS7xDIZxU5-fo5BdILwrvQI4BFnRutQa0eQ5xAw2S4KtzIMa_1gCXI6-NM=@protonmail.com
State Accepted
Headers show
Series [bug#51920,v2] gnu: Add inkbox. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 28, 2021, 7:12 p.m. UTC
Hi Nicolas,

> Hello,
>
> phodina via Guix-patches via guix-patches@gnu.org writes:
>
> > -   gnu/packages/qt.scm (inkbox): New variable.
>
> Thank you. Some comments follow.
>
> First, this should go to "ebook.scm" instead of "qt.scm".

Thanks, that is a better place to put it.
>
> > -   (source (origin
>
> You should instead a newline before "(origin".

Fixed.
>
> > -                (method git-fetch)
> >
> >
> > -                (uri
> >
> >
> > -                 (git-reference
> >
> >
> > -                  (url "https://alpinekobox.ddns.net/InkBox/inkbox/")
> >
> >
> > -                  (commit version)))
> >
> >
> > -                (file-name (git-file-name name version))
> >
> >
> > -                (sha256
> >
> >
> > -                 (base32
> >
> >
> > -                  "126cqn0ixcn608lv2hd9f7zmzj4g448bnpxc7wv9cvg83qqajh5n"))))
> >
> >
>
> Nitpick: hash should go on the same line as base32.

Fixed.
>
> > -   (build-system qt-build-system)
> > -   (arguments
> > -       '(#:tests? #f
> >
> >
>
> You should add a comment explaining why tests are disabled (i.e.: there
>
> is no tests).

Fixed.
>
> > -         #:phases
> >
> >
> > -         (modify-phases %standard-phases
> >
> >
> > -           (add-after 'unpack 'prefix-opt
> >
> >
> > -             (lambda* _
> >
> >
> > -               (substitute* "inkbox.pro"
> >
> >
> > -                 (("/opt/\\\\$\\\\$\\\\{TARGET\\\\}") (string-append (assoc-ref %outputs "out"))))))
> >
> >
>
> You should use (lambda* (#:key outputs #:allow-other-keys) ...) and then
>
> (assoc-ref outputs "out") instead.
>
> > -           (replace 'configure
> >
> >
> > -             (lambda* (#:key make-flags #:allow-other-keys)
> >

Thanks, that is the correct syntax.
> >
> > -               (apply invoke (cons "qmake" make-flags)))))))
> >
> >
> > -   (native-inputs
> > -       `(("qtbase" ,qtbase-5)))
> >
> >
>
> Does it fail with qtbase 6?
Unfortunately it does not compile though it shouldn't be that hard to port it. But here it is about packaging.
>
> > -   (license license:gpl1)))
>
> License is actually gpl3, according to LICENSE file.

Sorry, my mistake.
>
> Could you send an updated patch?
>
> Regards,
> --------------------------------------------------------------------------------------------------
>
> Nicolas Goaziou

Thanks for the remarks!

----
Petr

Comments

Nicolas Goaziou Nov. 29, 2021, 9:21 p.m. UTC | #1
Hello,

phodina <phodina@protonmail.com> writes:

> Subject: [PATCH v2] gnu: Add inkbox.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 9de0cd711006728bfbaaf6f0bc39bc7cd2c22915 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Wed, 10 Nov 2021 22:24:33 +0100
Subject: [PATCH v2] gnu: Add inkbox.

* gnu/packages/qt.scm (inkbox): New variable.

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index abb04b6d93..b2bf4e6dfb 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 la snesne <lasnesne@lagunposprasihopre.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -35,6 +36,7 @@  (define-module (gnu packages ebook)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system qt)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
@@ -376,6 +378,42 @@  (define-public ebook-tools
 accessing and converting various ebook file formats.")
     (license license:expat)))
 
+(define-public inkbox
+  (package
+    (name "inkbox")
+    (version "1.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://alpinekobox.ddns.net/InkBox/inkbox/")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "126cqn0ixcn608lv2hd9f7zmzj4g448bnpxc7wv9cvg83qqajh5n"))))
+    (build-system qt-build-system)
+    (arguments
+     '(#:tests? #f                      ; no test suite
+       #:make-flags
+       (list (string-append "PREFIX="
+                            (assoc-ref %outputs "out")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'prefix-opt
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "inkbox.pro"
+               (("/opt/\\$\\$\\{TARGET\\}") (string-append (assoc-ref outputs "out"))))))
+         (replace 'configure
+           (lambda* (#:key make-flags #:allow-other-keys)
+             (apply invoke (cons "qmake" make-flags)))))))
+    (native-inputs
+     `(("qtbase" ,qtbase-5)))
+    (home-page "https://alpinekobox.ddns.net/InkBox/inkbox/")
+    (synopsis "EBook reader")
+    (description "This package provides InkBox eBook reader.")
+    (license license:gpl3)))
+
 (define-public liblinebreak
   (package
     (name "liblinebreak")
-- 
2.33.0