diff mbox series

[bug#52251] gnu: Add python-django-svg-image-form-field.

Message ID N95fF9SMVGghwuv3-OKENglap_Z9Mr_pz9czFt5w_UyEwPJMBkwGx0zncZR_cZHAR9ru-WizhDKF1ZWBQSL2EAlzdn1JKfIdSIC07-ECS30=@protonmail.com
State Accepted
Headers show
Series [bug#52251] gnu: Add python-django-svg-image-form-field. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Luis Felipe Dec. 2, 2021, 10:39 p.m. UTC
Hi, a new package here.

---
Luis Felipe López Acevedo
https://luis-felipe.gitlab.io/

Comments

Nicolas Goaziou Dec. 5, 2021, 8:50 p.m. UTC | #1
Hello,

Luis Felipe via Guix-patches via <guix-patches@gnu.org> writes:

> Hi, a new package here.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 4ba12d5def43024151ab1f5323177b7a74aa2271 Mon Sep 17 00:00:00 2001
From: Luis Felipe <luis.felipe.la@protonmail.com>
Date: Thu, 2 Dec 2021 15:48:05 -0500
Subject: [PATCH] gnu: Add python-django-svg-image-form-field.

* gnu/packages/django.scm (python-django-svg-image-form-field): New
variable.
---
 gnu/packages/django.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 9fe0e8d3d1..32a14d3f58 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
 ;;; Copyright © 2019 Sam <smbaines8@gmail.com>
 ;;; Copyright © 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1357,3 +1358,28 @@  (define-public python-django-url-filter
 and also specify the lookup type for each filter (very much like
 Django's filtering system in ORM).")
     (license license:expat)))
+
+(define-public python-django-svg-image-form-field
+  (package
+    (name "python-django-svg-image-form-field")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/artrey/django-svg-image-form-field")
+             (commit (string-append version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "131m545khn8l20j4x2bvlvz36dlbnhj9pc98i2dw72s3bw8pgws0"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-defusedxml" ,python-defusedxml)
+       ("python-django" ,python-django)
+       ("python-pillow" ,python-pillow)))
+    (home-page "https://github.com/artrey/django-svg-image-form-field")
+    (synopsis "Form field to validate SVG and other images")
+    (description "This form field allows users to provide SVG images for
+models that use Django's standard @code{ImageField}, in addition to the
+image files already supported by it.")
+    (license license:expat)))
-- 
2.33.0