diff mbox series

[bug#54601] Add python-flask-compress and python-flask-seasurf

Message ID MzBtpau--3-2@tutanota.com
State New
Headers show
Series [bug#54601] Add python-flask-compress and python-flask-seasurf | expand

Commit Message

Deslauriers, Douglas via Guix-patches" via March 27, 2022, 7:43 p.m. UTC

Comments

M March 27, 2022, 7:47 p.m. UTC | #1
kiasoc5--- via Guix-patches via schreef op zo 27-03-2022 om 21:43
[+0200]:
> +    (synopsis
> +      "Compress responses in your Flask app with gzip, deflate or
> brotli.")
> +    (description
> +      "Compress responses in your Flask app with gzip, deflate or
> brotli.")

The description is missing, and ‘do foo in your Brand(TM) app’ reads
like marketing.  ’(guix)Synopses and Descriptions’ recommends longer,
and more descriptive, descriptions.  E.g., what do ‘responses’ mean
here?  Is it Flask-exclusive, or can it also be used outside a Flask
context?

Greetings,
Maxime.
Ricardo Wurmus July 10, 2023, 11:29 a.m. UTC | #2
I updated the patches for the latest versions, used the
pyproject-build-system, and trimmed the descriptions a bit.

Pushed to the master branch.  Thank you!
diff mbox series

Patch

From 7664077a8444286755cf82168d7dc2ad7efb06c1 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Sun, 27 Mar 2022 15:27:59 -0400
Subject: [PATCH 2/2] gnu: Add python-flask-seasurf.

* gnu/packages/python-web.scm (python-flask-seasurf): New variable.
---
 gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3de2629b29..931d1500b7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6408,3 +6408,28 @@  (define-public python-flask-compress
     (description
       "Compress responses in your Flask app with gzip, deflate or brotli.")
     (license license:expat)))
+
+(define-public python-flask-seasurf
+  (package
+  (name "python-flask-seasurf")
+  (version "0.3.1")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-SeaSurf" version))
+      (sha256
+        (base32 "04yfwln40iji7vn517mmkflnzxy7wa11yfhs124rch4s7pqhvygz"))))
+  (build-system python-build-system)
+    (arguments
+         `(#:phases
+           (modify-phases %standard-phases
+             (replace 'check
+               (lambda* (#:key tests? #:allow-other-keys)
+                 (when tests?
+                   (invoke "python" "-m" "unittest")))))))
+  (propagated-inputs (list python-flask))
+  (native-inputs (list python-tox))
+  (home-page "https://github.com/maxcountryman/flask-seasurf/")
+  (synopsis "An updated CSRF extension for Flask.")
+  (description "An updated CSRF extension for Flask.")
+  (license license:bsd-3)))
-- 
2.35.1