diff mbox series

[bug#53867] update python-flask-babel and fix searx build

Message ID MvMY2zn--B-2@tutanota.com
State Accepted
Headers show
Series [bug#53867] update python-flask-babel and fix searx build | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

iyzsong--- via Guix-patches via Feb. 8, 2022, 4:16 a.m. UTC
Patch 2 fixes the sanity check for searx.

Comments

Nicolas Goaziou Feb. 9, 2022, 2:35 p.m. UTC | #1
Hello,

kiasoc5--- via Guix-patches via <guix-patches@gnu.org> writes:

> Patch 2 fixes the sanity check for searx.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 92627bdf98793cd0195c3dcacb822cd70bb53bb3 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Mon, 7 Feb 2022 10:31:13 -0500
Subject: [PATCH 2/2] gnu: searx: Fix build.

* gnu/packages/search.scm (searx)[arguments]<#:phases>: Simplify relax-requirements phase for updated dependencies. Add phase to allow sanity check to pass.
---
 gnu/packages/search.scm | 15 +++++++--------
 1 file changed, 7 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index ea1c555201..12879900dd 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -243,16 +243,15 @@  (define-public searx
        (modify-phases %standard-phases
          (add-after 'unpack 'relax-requirements
            (lambda _
-             ;; These packages are outdated in Guix at the time of packaging.
-             ;; When they are updated, remove corresponding substitutions.
              ;; Tests can run after build with 'searx-checker' tool in /bin.
+             ;; allow using a higher dependency version
              (substitute* "requirements.txt"
-               (("flask-babel==2.0.0") "flask-babel>=1.0.0")
-               (("jinja2==2.11.3") "jinja2>=2.11.2")
-               (("lxml==4.6.3") "lxml>=4.4.2")
-               (("pygments==2.8.0") "pygments>=2.7.3")
-               (("requests\\[socks\\]==2.25.1") "requests>=2.25")
-               (("==") ">=")))))))
+               (("==") ">="))))
+         (add-before 'sanity-check 'set-debug
+           (lambda _
+             ;; the user will need to change the secret key
+             ;; https://github.com/searx/searx/issues/2278
+             (setenv "SEARX_DEBUG" "1"))))))
     (propagated-inputs
      (list python-babel
            python-certifi
-- 
2.35.1