diff mbox series

[bug#51810] gnu: Add python-discord.py.

Message ID MoOW8kq--3-2@tuta.io
State New
Headers show
Series [bug#51810] gnu: Add python-discord.py. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur Nov. 13, 2021, 1:37 p.m. UTC

diff mbox series

Patch

From 3eac8e320d0f31e74b7ce649881625244c777929 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Sat, 13 Nov 2021 16:33:59 +0300
Subject: [PATCH] gnu: Add python-discord.py.

* gnu/packages/python-xyz.scm (python-discord.py): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5cdaad..027e957 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -111,6 +111,7 @@ 
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 Adam Kandur <rndd@tuta.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2076,6 +2077,28 @@  (define-public python-diskcache
     (description "DiskCache is a disk and file backed persistent cache.")
     (license license:asl2.0)))
 
+(define-public python-discord.py
+  (package
+    (name "python-discord.py")
+    (version "1.7.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Rapptz/discord.py")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0la2fcfn25xgy0iag6w2kjrpm7xqpa0zyy77cmfimksjc76c59bq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-aiohttp" ,python-aiohttp)))
+    (home-page "https://discordpy.readthedocs.io/en/stable")
+    (synopsis "An API wrapper for Discord written in Python")
+    (description
+     "Modern, easy to use, feature-rich, and async ready API wrapper for Discord.")
+    (license license:expat)))
+
 (define-public python-bitstruct
   (package
     (name "python-bitstruct")
-- 
2.33.1