diff mbox series

[bug#49577] Add python-pmbootstrap

Message ID MdOBhls2XZW2lUHnTteaeKJhRlGDu5cpCrPs5rWv5Xfg9FITtzxhWXdUj2AKsw5Phn0mT6MhFizWNJTtXX376A8UXSJT2MtYkU0eYo3_i3U=@protonmail.com
State New
Headers show
Series [bug#49577] Add python-pmbootstrap | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina July 15, 2021, 4:31 p.m. UTC
---
index d8c3fbec07..0ccd115416 100644
--
2.31.1

Comments

jgart March 13, 2023, 5:21 a.m. UTC | #1
Hi,

What's the status on this?

Regarding the tests, you can try disabling the same ones that are disabled in the nixpkgs pmboostrap:

https://github.com/NixOS/nixpkgs/blob/nixos-unstable/pkgs/tools/misc/pmbootstrap/default.nix#L31
diff mbox series

Patch

--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -985,6 +985,31 @@  and URL-safe UUIDs.  UUIDs are generated using the built-in Python @code{uuid}
 module and then similar looking characters are removed.")
     (license license:bsd-3)))

+(define-public python-pmbootstrap
+  (package
+    (name "python-pmbootstrap")
+    (version "1.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pmbootstrap" version))
+       (sha256
+        (base32
+         "1j796f4wrcdrjd7j9m3w3ziiyqq17kskil9bgy893j6sk73fc5q0"))))
+    (build-system python-build-system)
+    ;; TODO: Running tests fails
+    (arguments
+     '(#:tests? #f))
+    (inputs
+     `(("python-pytest" ,python-pytest) ("python-pyopenssl" ,python-pyopenssl)))
+    (propagated-inputs `(("openssl" ,openssl)))
+    (home-page "https://www.postmarketos.org")
+    (synopsis
+     "A sophisticated chroot / build / flash tool to develop and install postmarketOS")
+    (description
+     "A sophisticated chroot / build / flash tool to develop and install postmarketOS")
+    (license #f)))
+
 (define-public python-logwrap
   (package
     (name "python-logwrap")