diff mbox series

[bug#48797] gnu: Add emacs-vscode-dark-plus.

Message ID MbD5Mm0--3-2@tuta.io
State Accepted
Headers show
Series [bug#48797] gnu: Add emacs-vscode-dark-plus. | expand

Commit Message

Adam Kandur June 2, 2021, 7 p.m. UTC
From f0a27beb7dff2e0911e085ab950a757b84b3afde Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 2 Jun 2021 21:50:36 +0300
Subject: [PATCH] gnu: Add emacs-vscode-dark-plus.

* gnu/packages/emacs-xyz.scm (emacs-vscode-dark-plus): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

--
2.31.1

Comments

Nicolas Goaziou June 2, 2021, 7:43 p.m. UTC | #1
Hello,

Adam Kandur via Guix-patches via <guix-patches@gnu.org> writes:

> Subject: [PATCH] gnu: Add emacs-vscode-dark-plus.

Thank you. Some comments follow.
> +    (version "v2.0.0")

The version should be "2.0.0".

The "v" prefix should be appendend ...

> +       (uri (git-reference
> +             (url "https://github.com/ianyepan/vscode-dark-plus-emacs-theme")
> +             (commit version)))

... here with (string-append "v" version)

> +    (synopsis "A port of the default VS Code Dark+ theme")

The synopsis cannot start with the article "A". You may want to run guix
lint to catch this. I suggest the following:

    Emacs port of the default VS Code Dark+ theme

> +    (description
> +     "An accurate port of the default Visual Studio Code Dark+ theme for Emacs.  This theme aims to be as
> +identical as possible to the default Dark+ color scheme used by Visual Studio Code.")

The description cannot start with the article "An" either. See above.
Besides, the two sentences have the same meaning. I suggest to drop the
first one.

> +    (license license:gpl3)))

The license is actually gpl3+ if you look at the header of
"vscode-dark-plus-theme.el".

Also, there seems to be an issue with white spaces.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a1083f9..5a38935 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -425,6 +425,27 @@  repositories through the
server}.  The main advantage compared to @code{vc-hg} is speed.")
     (license license:gpl3+)))

+(define-public emacs-vscode-dark-plus
+  (package
+    (name "emacs-vscode-dark-plus")
+    (version "v2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ianyepan/vscode-dark-plus-emacs-theme")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1vcaqvhdgr91pr7kqskbscs8awm8jp6dkh79h6w36i9ipmc4l4hl"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/ianyepan/vscode-dark-plus-emacs-theme")
+    (synopsis "A port of the default VS Code Dark+ theme")
+    (description
+     "An accurate port of the default Visual Studio Code Dark+ theme for Emacs.  This theme aims to be as
+identical as possible to the default Dark+ color scheme used by Visual Studio Code.")
+    (license license:gpl3)))
+
(define-public emacs-hyperbole
   (package
     (name "emacs-hyperbole")