diff mbox series

[bug#48512] gnu: Add python-playsound.

Message ID Ma0hilj--3-2@tuta.io
State New
Headers show
Series [bug#48512] gnu: Add python-playsound. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur May 18, 2021, 11:02 p.m. UTC
From 812f4897ab8f32f2a9c716246a48b03892d25798 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 19 May 2021 01:58:16 +0300
Subject: [PATCH] gnu: Add python-playsound.

* gnu/packages/python-xyz.scm (python-playsound): New variable.
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

--
2.31.1

Comments

Hartmut Goebel Feb. 15, 2024, 8:48 a.m. UTC | #1
Hi,

this software seems to have some release. Why are you not using this 
version but call it "0.0.0"? What random commit is it? Please add a comment.

Anyhow, I'm in favor of *not* including this package at all, since it 
seems to be unmaintained since three years. And we should not include 
dead software.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f79fc54e24..66d281144a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12409,6 +12409,27 @@  Pytest but stripped of Pytest specific details.")
code.")
     (license license:expat)))

+(define-public python-playsound
+  (let ((revision "0")
+        (commit "907f1fe73375a2156f7e0900c4b42c0a60fa1d00"))
+    (package
+      (name "python-playsound")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+	       (url "https://github.com/TaylorSMarks/playsound")
+	       (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1fh3m115h0c57lj2pfhhqhmsh5awzblb7csi1xc5a6f6slhl059k"))))
+      (build-system python-build-system)
+      (home-page "https://github.com/TaylorSMarks/playsound")
+      (synopsis "Function module for playing sounds")
+      (description "Pure Python, cross platform, single function module with no dependencies for playing sounds.")
+      (license license:expat))))
+
(define-public python-deprecation
   (package
     (name "python-deprecation")