diff mbox series

[bug#47811] gnu: Add sbcl-bodge-blobs-support.

Message ID MYMrwl0--7-2@tuta.io
State Accepted
Headers show
Series [bug#47811] gnu: Add sbcl-bodge-blobs-support. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur April 15, 2021, 11:31 p.m. UTC
From eeac3552e0a6df41e38f6cddf703fd41fbee8b7a Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Fri, 16 Apr 2021 02:29:58 +0300
Subject: [PATCH] gnu: Add sbcl-bodge-blobs-support.

* gnu/packages/lisp-xyz.scm (sbcl-bodge-blobs-support): New variable.
---
 gnu/packages/lisp-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Guillaume Le Vaillant April 16, 2021, 11:57 a.m. UTC | #1
Patch pushed as 4d7b6df58e1df58a4faecc25d14a3897669da59a with some
modifications.
I changed the package to use a commit directly instead of the "stable"
tag, in case this tag gets reassigned upstream to an updated stable
state of the branch, which would break the reproducibility of the source
archive created by Guix.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f340360..320875c 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15578,6 +15578,38 @@  immediately loaded.")
 (define-public cl-bodge-math
   (sbcl-package->cl-source-package sbcl-bodge-math))
 
+(define-public sbcl-bodge-blobs-support
+  (package
+    (name "sbcl-bodge-blobs-support")
+    (version "stable")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/borodust/bodge-blobs-support")
+             (commit version)))
+       (file-name (git-file-name "bodge-blobs-support" version))
+       (sha256
+        (base32 "02nd1x6y1akp1ymv1y4z9ympwbnpd1drwi4f86xbjszxqff6jyj8"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     `(#:asd-files '("bodge-blobs-support.asd")
+       #:asd-systems '("bodge-blobs-support")))
+    (native-inputs
+     `(("trivial-features" ,sbcl-trivial-features)
+       ("sbcl-alexandria" ,sbcl-alexandria)
+       ("cffi" ,sbcl-cffi)))
+    (home-page "https://github.com/borodust/bodge-blobs-support")
+    (synopsis "Common utilities for blob packages")
+    (description "Library for simplifying packaging and loading of compiled foreign library collection.")
+    (license license:unlicense)))
+
+(define-public cl-bodge-blobs-support
+  (sbcl-package->cl-source-package sbcl-bodge-blobs-support))
+
+(define-public ecl-bodge-blobs-support
+  (sbcl-package->ecl-package sbcl-bodge-blobs-support))
+
 (define-public sbcl-cl-conspack
   (let ((commit "fc8473bc6f929696b03b43820596b7c976c4678e")
         (revision "1"))