diff mbox series

[bug#47728] gnu: Add sbcl-bodge-queue.

Message ID MY5W6tU--3-2@tuta.io
State Accepted
Headers show
Series [bug#47728] gnu: Add sbcl-bodge-queue. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur April 12, 2021, 2:37 p.m. UTC
From 5ad8fb5f87ab91feaf99a30f8a823857feabfb63 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Mon, 12 Apr 2021 17:35:19 +0300
Subject: [PATCH] gnu: Add sbcl-bodge-queue.

* gnu/packages/lisp-xyz.scm (sbcl-bodge-queue): New variable.
---
 gnu/packages/lisp-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Guillaume Le Vaillant April 12, 2021, 3:09 p.m. UTC | #1
Patch pushed as c1ed3b048d6644b70221eac2dc9b67420a999462 with some
modifications.
Thanks.
Adam Kandur April 12, 2021, 3:31 p.m. UTC | #2
why you have added sbcl-fiveam to native inputs?
Guillaume Le Vaillant April 12, 2021, 4:39 p.m. UTC | #3
Adam Kandur via Guix-patches via <guix-patches@gnu.org> skribis:

> why you have added sbcl-fiveam to native inputs?

In the asd file, the "bodge-queue/tests" system for the tests depends on
fiveam. As the tests are run only at build time, their dependencies are
only required at build time and not at run time, so we put them in
'native-inputs' instead of 'inputs'.
Sharlatan Hellseher April 12, 2021, 7:41 p.m. UTC | #4
@Adam Kandur

Are you planning to pack https://github.com/borodust/bodge-concurrency as well?

I put to my queue to pack https://github.com/borodust/cl-bodge, if you
are on the same way let's distribute efforts :)

I update my progress her
https://github.com/Hellseher/guix-patches/blob/main/lisp-xyz.org
-- 
… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Guillaume Le Vaillant April 12, 2021, 8:38 p.m. UTC | #5
Adam Kandur <rndd@tuta.io> skribis:

> also, you wrote "fiveam" ,sbcl-fiveam
>
> why not "sbcl-fiveam" ,sbcl-fiveam

It's because of the cl-xxx and ecl-xxx packages that are created by
transforming the definition of the sbcl-xxx package to use cl-* or ecl-*
packages as inputs instead of sbcl-*.

If the sbcl-xxx package has '("sbcl-fiveam" ,sbcl-fiveam)' as input,
after transformation the ecl-xxx package will have
'("sbcl-fiveam" ,ecl-fiveam)' as inputs, which looks strange (but it
will work anyway as the string is just used to reference an input in
custom phases using something like '(assoc-ref inputs "sbcl-xxx")').

By using just "fiveam" as string, the sbcl-xxx package has
'("fiveam" ,sbcl-fiveam)' as input, and the ecl-xxx package will have
'("fiveam" ,ecl-fiveam)'.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1d8e0b4..8fdea54 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -161,6 +161,34 @@  collection.")
 (define-public cl-bodge-utilities
   (sbcl-package->cl-source-package sbcl-bodge-utilities))
 
+(define-public sbcl-bodge-queue
+  (package
+    (name "sbcl-bodge-queue")
+    (version "stable")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/borodust/bodge-queue")
+             (commit version)))
+       (file-name (git-file-name "bodge-queue" version))
+       (sha256
+        (base32 "0f4252i8pfy5s4v7w1bpjawysn4cw7di405mqsx2h7skv27hvpz6"))))
+    (build-system asdf-build-system/sbcl)
+    (arguments
+     `(#:asd-files '("bodge-queue.asd")
+       #:asd-systems '("bodge-queue")))
+    (home-page "https://github.com/borodust/bodge-queue")
+    (synopsis "FIFO, not FIFA")
+    (description "Simple FIFO implementation with no external dependencies")
+    (license license:expat)))
+
+(define-public cl-bodge-queue
+  (sbcl-package->cl-source-package sbcl-bodge-queue))
+
+(define-public ecl-bodge-queue
+  (sbcl-package->ecl-package sbcl-bodge-queue))
+
 (define-public sbcl-golden-utils
   (let ((commit "62a5cb948a011eb26e7a89f56d5839a3334b4100")
         (revision "2"))