diff mbox series

[bug#47506] gnu: fiano-fmap: turn off tests to build program.

Message ID MX4K52s--3-2@tuta.io
State New
Headers show
Series [bug#47506] gnu: fiano-fmap: turn off tests to build program. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Adam Kandur March 30, 2021, 10:50 p.m. UTC
From b5a149a0ae68eb2692463f0d77f3da686ff23864 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 31 Mar 2021 01:46:49 +0300
Subject: [PATCH] gnu: fiano-fmap: turn off tests to build program.

* gnu/packages/admin.scm (fiano-fmap): turn off tests to build program.
---
 gnu/packages/admin.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Jack Hill March 31, 2021, 6:28 a.m. UTC | #1
Hi,

Thanks for your interest in fiano-fmap!

On Wed, 31 Mar 2021, Adam Kandur via Guix-patches via wrote:

>
> From b5a149a0ae68eb2692463f0d77f3da686ff23864 Mon Sep 17 00:00:00 2001
> From: Adam Kandur <rndd@tuta.io>
> Date: Wed, 31 Mar 2021 01:46:49 +0300
> Subject: [PATCH] gnu: fiano-fmap: turn off tests to build program.
>
> * gnu/packages/admin.scm (fiano-fmap): turn off tests to build program.
> ---
>  gnu/packages/admin.scm | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 292a4bc..14f7864 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -4431,7 +4431,9 @@ disk utilization, priority, username, state, and exit code.")
>      (name "fiano-fmap")
>      (arguments
>       `(#:import-path "github.com/linuxboot/fiano/cmds/fmap"
> -       #:unpack-path "github.com/linuxboot/fiano"))))
> +       #:unpack-path "github.com/linuxboot/fiano"
> +       ;; tests dont work
> +       #:tests? #f))))
>  
>  (define-public novena-eeprom
>    (package
>

When I first noticed the test failure in #45172 [0] it wasn't clear to me 
that the test failure was harmless rather than exhibiting an actual problem 
in our fiano-fmap package. Can you confirm that the package works as 
expected? I also wonder if we could make a smaller change and just disable 
the problematic test rather than the whole suite.

I've also noticed that fiano-fmap has a release candidate for version 
6.0.0. I wonder if that version fixes the problem (I may have to give it a 
try, although this one may come back to needing improvements in the 
go-build-system).

[0] https://issues.guix.gnu.org/45172

Best,
Jack
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 292a4bc..14f7864 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4431,7 +4431,9 @@  disk utilization, priority, username, state, and exit code.")
     (name "fiano-fmap")
     (arguments
      `(#:import-path "github.com/linuxboot/fiano/cmds/fmap"
-       #:unpack-path "github.com/linuxboot/fiano"))))
+       #:unpack-path "github.com/linuxboot/fiano"
+       ;; tests dont work
+       #:tests? #f))))
 
 (define-public novena-eeprom
   (package