[bug#72500] Add: rofi-emoji-wayland.

Message ID MW4PR84MB1371821CA6791B5690B0679199B82@MW4PR84MB1371.NAMPRD84.PROD.OUTLOOK.COM
State New
Headers
Series [bug#72500] Add: rofi-emoji-wayland. |

Commit Message

Jaft Aug. 7, 2024, 12:07 a.m. UTC
  Sending these both to the same bug since the Wayland version depends on the first patch.
I don't think they're so drastically different as to require two separate issue numbers but let me know if that's preferred and I can open a new one for this patch.
    On Tuesday, August 6, 2024 at 07:05:04 PM CDT, Wamm K. D. <jaft.r@outlook.com> wrote:  
 
 * gnu/packages/xdisorg.scm (rofi-emoji-wayland): New variable.
---
 gnu/packages/xdisorg.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
  

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bb95304a1f..cfcccb3e81 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2139,6 +2139,25 @@  (define-public rofi-emoji
    (home-page "https://github.com/Mange/rofi-emoji")
    (license license:expat)))
 
+(define-public rofi-emoji-wayland
+  (package/inherit rofi-emoji
+    (name "rofi-emoji-wayland")
+    (arguments (substitute-keyword-arguments (package-arguments rofi-emoji)
+                ((#:phases phases)
+                  #~(modify-phases #$phases
+                      (replace 'patch-adapter-script-xdotool
+                        (lambda* (#:key inputs #:allow-other-keys)
+                          (substitute* "clipboard-adapter.sh"
+                            (("wtype") (search-input-file inputs
+                                                          "/bin/wtype")))))))))
+  (inputs (modify-inputs (package-inputs rofi-emoji)
+            (replace "xdotool" wtype)))
+  (propagated-inputs (modify-inputs (package-propagated-inputs rofi-emoji)
+                      (replace "rofi" rofi-wayland)))
+  (description (string-append
+                (package-description rofi-pass)
+                "\nThis package provides Wayland support by default."))))
+
 (define-public tint2
  (package
    (name "tint2")