diff mbox series

[bug#46011] well, not really, here is a new commit

Message ID MR_1Bt1--3-2@tuta.io
State Accepted
Headers show
Series [bug#46011] well, not really, here is a new commit | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

ashish.is--- via Guix-patches" via Jan. 21, 2021, 1:01 p.m. UTC
From cc450bb85b138bcb72915a32bfeb9eab27481c40 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Thu, 21 Jan 2021 15:57:09 +0300
Subject: [PATCH] gnu: Add sbcl-claw-utils.

* gnu/packages/lisp-xyz.scm (sbcl-claw-utils): New variable.
---
 gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Guillaume Le Vaillant Jan. 21, 2021, 1:36 p.m. UTC | #1
Patch pushed as ef9c5247a34580d82a1675eea6242bbe065440cd.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 36725eb..e2a208a 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12225,6 +12225,35 @@  package.")
 and lean bindings to C libraries.")
       (license license:bsd-2))))
 
+(define-public sbcl-claw-utils
+  (let ((revision "0")
+        (commit "efe25016501973dc369f067a64c7d225802bc56f"))
+    (package
+      (name "sbcl-claw-utils")
+      ;; version is not specified
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/borodust/claw-utils")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01df3kyf2qs3czi332dnz2s35x2j0fq46vgmsw7wjrrvnqc22mk5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-files '("claw-utils.asd")
+         #:asd-systems '("claw-utils")))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+     ("cffi" ,sbcl-cffi)
+     ("sbcl-claw" ,sbcl-claw)))
+      (home-page "https://github.com/borodust/claw-utils")
+      (synopsis "Utilities for easier autowrapping.")
+      (description "Various handy utilties to help autowrapping with @code{:claw}.")
+      (license license:expat))))
+
 (define-public cl-claw
   (sbcl-package->cl-source-package sbcl-claw))