diff mbox series

[bug#46011] gnu: Add sbcl-claw-utils.

Message ID MRXFLct--3-2@tuta.io
State Accepted
Headers show
Series [bug#46011] gnu: Add sbcl-claw-utils. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

ashish.is--- via Guix-patches" via Jan. 21, 2021, 12:04 a.m. UTC
From 4f2d2866690fa00b5fccc6cab15b97aabd4b8416 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Thu, 21 Jan 2021 03:02:32 +0300
Subject: [PATCH] gnu: Add sbcl-claw-utils.

* gnu/packages/lisp-xyz.scm (sbcl-claw-utils): New variable.
---
 gnu/packages/lisp-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Guillaume Le Vaillant Jan. 21, 2021, 10:51 a.m. UTC | #1
guix-patches--- via <guix-patches@gnu.org> skribis:

> +(define-public sbcl-claw-utils
> +  (let ((revision "0")
> +        (commit "efe25016501973dc369f067a64c7d225802bc56f"))
> +    (package
> +      (name "sbcl-claw-utils")
>        ...
> +      (inputs
> +       `(("alexandria" ,sbcl-alexandria)
> +     ("cffi" ,sbcl-cffi)
> +     ("sbcl-claw" ,sbcl-claw)
> +     ("sbcl-cl-autowrap" ,sbcl-cl-autowrap)))

Is the cl-autowrap package really necessary here? It is not in the
dependency list of the asd file, and it looks like the package compiles
fine without it. Or is there a case where it is required at runtime?
diff mbox series

Patch

diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 36725eb..f4eeaed 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12231,6 +12231,42 @@  and lean bindings to C libraries.")
 (define-public ecl-claw
   (sbcl-package->ecl-package sbcl-claw))
 
+(define-public sbcl-claw-utils
+  (let ((revision "0")
+        (commit "efe25016501973dc369f067a64c7d225802bc56f"))
+    (package
+      (name "sbcl-claw-utils")
+      ;; version is not specified
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/borodust/claw-utils")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01df3kyf2qs3czi332dnz2s35x2j0fq46vgmsw7wjrrvnqc22mk5"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       '(#:asd-files '("claw-utils.asd")
+         #:asd-systems '("claw-utils")))
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+     ("cffi" ,sbcl-cffi)
+     ("sbcl-claw" ,sbcl-claw)
+     ("sbcl-cl-autowrap" ,sbcl-cl-autowrap)))
+      (home-page "https://github.com/borodust/claw-utils")
+      (synopsis "Utilities for easier autowrapping.")
+      (description "Various handy utilties to help autowrapping with @code{:claw}.")
+      (license license:expat))))
+
+(define-public cl-claw-utils
+  (sbcl-package->cl-source-package sbcl-claw-utils))
+
+(define-public ecl-claw-utils
+  (sbcl-package->ecl-package sbcl-claw-utils))
+
 (define-public sbcl-array-operations
   (let ((commit "75cbc3b1adb2e3ce2109489753d0f290b071e81b")
         (revision "0"))