diff mbox series

[bug#60827,v6,3/4] gnu: Add xforms-gl.

Message ID MN2PR20MB2605D2109A893C2A53358A58ACAF9@MN2PR20MB2605.namprd20.prod.outlook.com
State New
Headers show
Series Add dozenal and dependencies. | expand

Commit Message

Jake Leporte Feb. 27, 2023, 12:39 a.m. UTC
* gnu/packages/xdisorg.scm (xforms-gl): New variable.
---
 gnu/packages/xdisorg.scm | 9 +++++++++
 1 file changed, 9 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ede84ab..50ca156 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3496,3 +3496,12 @@  (define-public xforms
 called @code{fdesign} that allows you to design a GUI for a program directly
 on the screen and which then writes out the necessary C code for it.")
       (license license:lgpl2.1+))))
+
+(define-public xforms-gl
+  (package
+    (inherit xforms)
+    (name "xforms-gl")
+    (propagated-inputs (modify-inputs (package-propagated-inputs xforms)
+                         (append mesa)))
+    (synopsis
+     "GUI toolkit for X based on the X11 Xlib library, with OpenGL support")))