diff mbox series

[bug#60827,v5,3/4] gnu: Add xforms-gl.

Message ID MN2PR20MB26057A3D8EB9164519CB0D74ACA69@MN2PR20MB2605.namprd20.prod.outlook.com
State New
Headers show
Series None | expand

Commit Message

Jake Leporte Feb. 18, 2023, 12:31 a.m. UTC
---
 gnu/packages/xdisorg.scm | 9 +++++++++
 1 file changed, 9 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ffeb8db..7efe65c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3442,3 +3442,12 @@  (define-public xforms
 called @code{fdesign} that allows you to design a GUI for a program directly
 on the screen and which then writes out the necessary C code for it.")
       (license license:lgpl2.1+))))
+
+(define-public xforms-gl
+  (package
+    (inherit xforms)
+    (name "xforms-gl")
+    (propagated-inputs (modify-inputs (package-propagated-inputs xforms)
+                         (append mesa)))
+    (synopsis
+     "GUI toolkit for X based on the X11 Xlib library, with OpenGL support")))