diff mbox series

[bug#61409] gnu: Add emacs-ligature.

Message ID MN2PR20MB26057465D5947E3F623C114BACDE9@MN2PR20MB2605.namprd20.prod.outlook.com
State New
Headers show
Series [bug#61409] gnu: Add emacs-ligature. | expand

Commit Message

Jake Leporte Feb. 10, 2023, 8:14 p.m. UTC
For this package, the author doesn't seem to have provided any
versioned releases, or even tags.  I've marked this as a git revision
of version "0.0", as I'm not sure what convention in this case is.  I
hope this is alright.

---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: b8f6ead5faac3c1b9a8fa6e060c00cf0917e884e
prerequisite-patch-id: 55ebfdbee35b36ac06da23b716337ecfef350452
prerequisite-patch-id: 6cb7b2d1972d3eeb5ad8b82239b17043e7263ab0
prerequisite-patch-id: 52c97b6e4d8d4b78217423a3f1323d95a609de8c
prerequisite-patch-id: 90b350ab4778843697da28bb10344a84ccacc70c
prerequisite-patch-id: 0d5a1f7cfe93822a3f3b11c19f4b2662a79cda17
prerequisite-patch-id: f6dd89498a48185e628f547b7f023a30547d8933
prerequisite-patch-id: 1a1a441a49fc8cad10ad161ab39b0fb73b19f42d
--
2.39.1

Comments

Nicolas Goaziou Feb. 11, 2023, 8:59 a.m. UTC | #1
Hello,

Jake Leporte <jakeleporte@outlook.com> writes:

> For this package, the author doesn't seem to have provided any
> versioned releases, or even tags.  I've marked this as a git revision
> of version "0.0", as I'm not sure what convention in this case is.  I
> hope this is alright.

In this case, we look for the "Version" keyword in the main file. Here,
its value is "1.0", so I used that as the base version.

The rest of the patch is perfect.

Applied. Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bbaafcc..c03db2d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4879,6 +4879,32 @@  (define-public emacs-keyfreq
 a command.")
     (license license:gpl3+)))

+(define-public emacs-ligature
+  (let ((commit "3d1460470736777fd8329e4bb4ac359bf4f1460a")
+        (revision "1"))
+    (package
+      (name "emacs-ligature")
+      (version (git-version "0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/mickeynp/ligature.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1rnx2mp8y1phnvfirmf4a6lza38dg2554r9igyijl9rgqpjax94d"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/mickeynp/ligature.el")
+      (synopsis "Typographic ligatures in Emacs")
+      (description
+       "This package maps ordinary graphemes (characters) to fancy
+ligatures, if both your version of Emacs and the font supports it.  With this
+package you can control where Emacs must display ligatures. That is useful if
+you only want a subset of the ligatures in certain major modes, for instance,
+or if you want to ensure that some modes have no ligatures at all.")
+      (license license:gpl3+))))
+
 (define-public emacs-olivetti
   (package
     (name "emacs-olivetti")