diff mbox series

[bug#61657] gnu: python-paste: Update to 3.5.2.

Message ID MN2PR20MB260532707C4D39FC3DE2F009ACA49@MN2PR20MB2605.namprd20.prod.outlook.com
State New
Headers show
Series [bug#61657] gnu: python-paste: Update to 3.5.2. | expand

Commit Message

Jake Leporte Feb. 20, 2023, 4:13 p.m. UTC
* gnu/packages/python-web.scm (python-paste): Update to 3.5.2.
---

This patch also fixes the failing build for python-paste.  I wasn't
able to determine why exactly the package won't build with
`python-build-system' vs. `pyproject-build-system', only that it
doesn't- it produces a traceback with a TypeError deep in the
setuptools code.  Switching to pyproject fixed the issue.

 gnu/packages/python-web.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 6dce27abbba01cb4e249c9bdb3c132cecc0a5c51
prerequisite-patch-id: 55ebfdbee35b36ac06da23b716337ecfef350452
prerequisite-patch-id: cc81d1d3eb9c0687793c8baf949901cd49c42650
prerequisite-patch-id: 52c97b6e4d8d4b78217423a3f1323d95a609de8c
prerequisite-patch-id: 90b350ab4778843697da28bb10344a84ccacc70c
prerequisite-patch-id: 0d5a1f7cfe93822a3f3b11c19f4b2662a79cda17
prerequisite-patch-id: f6dd89498a48185e628f547b7f023a30547d8933
prerequisite-patch-id: 1a1a441a49fc8cad10ad161ab39b0fb73b19f42d
--
2.39.1

Comments

Ludovic Courtès Feb. 24, 2023, 9:36 p.m. UTC | #1
Hi Jake,

Jake Leporte <jakeleporte@outlook.com> skribis:

> * gnu/packages/python-web.scm (python-paste): Update to 3.5.2.
> ---
>
> This patch also fixes the failing build for python-paste.  I wasn't
> able to determine why exactly the package won't build with
> `python-build-system' vs. `pyproject-build-system', only that it
> doesn't- it produces a traceback with a TypeError deep in the
> setuptools code.  Switching to pyproject fixed the issue.

Great.  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 758cd91..b12f86b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4599,23 +4599,23 @@  (define-public python-wtforms
 (define-public python-paste
   (package
     (name "python-paste")
-    (version "3.0.6")
+    (version "3.5.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Paste" version))
        (sha256
         (base32
-         "14lbi9asn5agsdf7r97prkjpz7amgmp529lbvfhf0nv881xczah6"))
+         "1xjakxrdvy4kgfy170gb9bl8zp9hqjjwh1h1vlik1pxw606399ym"))
        (patches (search-patches "python-paste-remove-timing-test.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
            ;; This test calls out to the internet.
            (delete-file "tests/test_proxy.py") #t))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-pytest python-pytest-runner python-nose))
+     (list python-pytest python-nose))
     (propagated-inputs
      (list python-six))
     (home-page "https://pythonpaste.readthedocs.io/")